Bug 113166 - Probing for modems hangs
Probing for modems hangs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-08 21:12 EST by Reuben Thomas
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 16:23:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Thomas 2004-01-08 21:12:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.23  [en]

Description of problem:
When I try to set up a modem connection, probing for modems hangs. I 
presume that this is related to my hardware; I have a Sony Vaio 
laptop which has a winmodem (unsupported by Fedora, but supported 
with the right Conexant driver), and a hardware modem in a PCMCIA 
Xircom Ethernet/modem combo card. "cardctl ident" says:

Socket 0:
  product info: "Xircom", "CreditCard Ethernet 10/100 + Modem 56", 
"CEM56", "1.00"
  manfid: 0x0105, 0x110a
  function: 2 (serial)


Version-Release number of selected component (if applicable):
1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. Try to make a new dialup network connection
2. When redhat-config-network probes for modems, it hangs
3.
    

Additional info:
Comment 1 Harald Hoyer 2004-01-12 06:50:05 EST
r-c-network probes through kudzu...

what does:
# kudzu -c MODEM -p
say?
Comment 2 Reuben Thomas 2004-01-12 06:54:25 EST
Ah, that's the problem. It produces the following (note the segfault 
at the end):

-
class: NETWORK
bus: PCMCIA
detached: 0
device: eth
driver: xirc2ps_cs
desc: "Xircom CEM56 Ethernet/Modem"
vendorId: 0105
deviceId: 110a
function: 0
slot: 0
-
class: MODEM
bus: PCI
detached: 0
driver: unknown
desc: "Conexant|HSF 56k Data/Fax Modem (Mob WorldW SmartDAA)"
vendorId: 14f1
deviceId: 2443
subVendorId: 104d
subDeviceId: 8083
pciType: 1
pcibus:  0
pcidev:  a
pcifn:  0
-
class: MODEM
bus: PCMCIA
detached: 0
driver: serial_cs
desc: "Xircom CEM56 Ethernet/Modem"
vendorId: 0105
deviceId: 110a
function: 1
slot: 0
-
class: MODEM
bus: SERIAL
detached: 0
device: ttyS3
driver: ignore
desc: "Generic Serial Modem"
Segmentation fault
Comment 3 Harald Hoyer 2004-01-12 07:54:11 EST
reassigning to kudzu
Comment 4 Bill Nottingham 2005-04-28 14:07:17 EDT
Apologies for the lack of response. Does this persist under FC3?

Can you get a strace of 'kudzu -p -c modem'?
Comment 5 Reuben Thomas 2005-04-28 16:10:36 EDT
Sorry, I no longer use Fedora (I now use Debian).
Comment 6 Bill Nottingham 2005-04-28 16:23:31 EDT
Closing for now; have not seen other reports of this and can't reproduce it here.

Note You need to log in before you can comment on or make changes to this bug.