Bug 113175 - sm-client: No local mailer defined
sm-client: No local mailer defined
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-09 06:24 EST by L.Malinov
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-13 05:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L.Malinov 2004-01-09 06:24:28 EST
Description of problem: When starting sendmail after a custom 
installation the messages started to appear:

sm-client: No local mailer defined
QueueDirectory (Q) option must be set

After generating my own sendmail.mc and running: make -C /etc/mail 
sendmail appears to be working normally on the system for remote 
users. However the above messages still appear everytime after 
restarting sendmail. After that if local users (logged on the 
console) try to send mail the same messages appear again:

[root@smallbox root]# mail lucho
Subject: test
.
Cc:
Null message body; hope that's ok
[root@smallbox root]# No local mailer defined
QueueDirectory (Q) option must be set

Procmail and m4 are installed and procmail is defined as a local 
mailer.

After applying the latest sendmail rpms the problem still exist.

Version-Release number of selected component (if applicable):

sendmail-8.12.8-9.90
procmail-3.22-9
m4-1.4.1-13

How reproducible:

See above

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian La Roche 2004-01-13 05:09:42 EST
Looks like a config problem of your local machine. Please check with the
sendmail documentation on the setup.

greetings,

Florian la Roche

Note You need to log in before you can comment on or make changes to this bug.