Bug 113180 - kino segfaults after prelink
kino segfaults after prelink
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-09 07:55 EST by Christian Iseli
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 18:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Iseli 2004-01-09 07:55:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Yesterday, I built the kino 0.7 package from the Fedora.us QA section:
http://bugzilla.fedora.us/show_bug.cgi?id=1153

It was working fine, but today, after the nightly prelink cron, this
is what I get:
(process:2997): Gnome-CRITICAL **: file gnome-program.c: line 869
(gnome_program_locate_file): assertion `program != NULL' failed

(process:2997): Gnome-CRITICAL **: file gnome-program.c: line 869
(gnome_program_locate_file): assertion `program != NULL' failed
Segmentation fault

After doing "prelink -u /usr/bin/kino", the program runs fine again
(The warning/error messages are/were always there).

Later, I tried:
$ prelink /usr/bin/kino
and
$ prelink -mR /usr/bin/kino

And it still worked... :-|  Unfortunately, I didn't think to make a
copy of the crashing executable... :-(

Version-Release number of selected component (if applicable):
prelink-0.3.0-13

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Compile kino-0.7 from the Fedora.us QA section (URL with bug ID
above), using "rpmbuild --rebuild ...".  Here are my rpm settings:
chris: cat /home/chris/.rpmrc
buildarchtranslate: athlon: athlon
chris: cat /home/chris/.rpmmacros
%debug_package  %{nil}
%_enable_debug_packages 0
It should boil down to "rpmbuild --rebuild --target athlon ..."
2.Let the cron prelink run
3.try it and see if it crashes...
    

Actual Results:  kino crashed with a SEGV

Expected Results:  kino should have run normaly

Additional info:

Note You need to log in before you can comment on or make changes to this bug.