Bug 113192 - Undefined symbol dmi_broken on RPM rebuild
Undefined symbol dmi_broken on RPM rebuild
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2004-01-09 10:30 EST by diego.santacruz
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Proposed patch: rename i2c dmi_scan.{c,h} to i2c-dmi_scan.{c,h} (13.50 KB, patch)
2004-01-09 10:31 EST, diego.santacruz
no flags Details | Diff

  None (edit)
Description diego.santacruz 2004-01-09 10:30:30 EST
Description of problem:

When attepting to rebuild the kernel RPM (from the .src.rpm) the
dmi_broken symbol exported from arch/i386/kernel/dmi_scan.c is not
versioned, leading to unresolved symbols in the powernow-k7 module

Version-Release number of selected component (if applicable):
2.4.22-1.2140 (but also previous releases)

How reproducible:

Additional info:

I tracked the problem to the fact that the lm_sensors patch adds
another file named dmi_scan.c in drivers/i2c/. Since both dmi_scan.c
files export symbols the modversioning stuff picks only one, and that
happens to be the i2c one (at least on my machine).

I solved the problem by renaming the i2c dmi_scan.{c,h} files to
i2c-dmi_scan.{c,h}. Although there is maybe a saner approach?
Patch next.
Comment 1 diego.santacruz 2004-01-09 10:31:57 EST
Created attachment 96858 [details]
Proposed patch: rename i2c dmi_scan.{c,h} to i2c-dmi_scan.{c,h}

The patch is really simple, but has the drawback on renaming the module.
Comment 2 diego.santacruz 2004-01-09 10:48:04 EST
On a second thought, maybe it's better to upgrade the lm_sensors
kernel patch? Currently is a 2.6.5, which is really old. Or is it too
much work?
Comment 3 Axel Thimm 2004-02-24 05:17:48 EST
Later lm_sensors/i2c have the same behaviour. By coincidence I posted
on the same day about this on the lm_sensors list:


I just verified the same for FC1 2174 kernel and lm_sensors/i2c 2.8.4.

BTW patched FC1 kernels with recent lm_sensors/i2c support and the
matching lm_snesors userland bits can be found at ATrpms.net at the
cost of breaking powernow-k7.o
Comment 4 Dave Jones 2004-06-19 11:14:18 EDT

*** This bug has been marked as a duplicate of 126342 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.