This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1131931 - qupzilla included non-free icons.
qupzilla included non-free icons.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qupzilla (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2014-08-20 06:52 EDT by mejiko
Modified: 2015-09-14 15:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 15:59:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mejiko 2014-08-20 06:52:27 EDT
Hello.

qupzilla included non-free icons. (I think)


File list:


A) "qupzilla-1.4.4/bin/themes/*/images/flash.png"

B) "qupzilla-1.4.4/src/lib/data/icons/browsers/*" (except that html.png)

C) "qupzilla-1.4.4/src/lib/data/icons/sites/*" (except that liferea.png and akregator.png)


Question: Is there files is copyright and/or trademark problem ? 

I think that it is copyright and/or trademark problematic, It is non-free.


See:

A)

https://www.adobe.com/legal/permissions/trademarks.html
https://www.adobe.com/legal/permissions/icons-web-logos.html

B)

http://www.google.com/permissions/using-the-logo.html
http://www.google.com/permissions/trademark/our-trademarks.html
http://www.operasoftware.com/press/trademark
https://www.mozilla.org/en-US/foundation/trademarks/policy/

C)

http://www.netvibes.com/static.php?show=tos
http://www.bloglines.com/tos
https://duckduckgo.com/
https://duck.co/forum/thread/2733/duckduckgo-logo-license
http://www.google.com/permissions/using-the-logo.html
http://www.google.com/permissions/trademark/our-trademarks.html
https://info.yahoo.com/legal/us/yahoo/permissions/guidelines/
https://developers.google.com/youtube/branding_guidelines
https://www.youtube.com/yt/brand/using-logo.html
https://wikimediafoundation.org/wiki/Trademark_policy


Suggests:

1. Remove non-free icons and rebuild.

2. Replace Fedora free (Fedora acceptable licensed) icons.

3. Remove Fedora repos.


Thanks.
Comment 1 mejiko 2014-08-20 06:53:22 EDT
Blocking FE-Legal, This is copyright and/or trademark problem.
Comment 2 mejiko 2014-10-16 06:05:57 EDT
How it this bug current status ? 
Is this bug is resolved ?

Thanks.
Comment 3 Christoph Wickert 2014-10-17 11:18:24 EDT
I am waiting for a clarification from legal.
Comment 4 Tom "spot" Callaway 2014-10-21 15:49:17 EDT
In the case of the Adobe Flash thumbnail icon, there is clearly no permission from Adobe to use it in this context (and Adobe has a clear policy around their trademark usage).

For the other browser logos, there is also no permission from the owners (and each of them have clear policies around their trademark usage). Additionally, this inclusion is potentially confusing, since qupzilla is, itself, a browser.

The same is true for the site icons.

Honestly, I'm not sure why qupzilla needs all of these trademarked icons, instead of simply pulling them down from the requisite websites as needed upon loading.

Regardless, these trademarked files need to be removed (or the package removed from Fedora).
Comment 5 Jaroslav Reznik 2015-03-03 11:13:39 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 6 Raphael Groner 2015-03-31 08:42:26 EDT
Please remove the illegal content, asap.
Comment 7 Helio Chissini de Castro 2015-04-06 16:54:25 EDT
The icons are replaced for generic ones since 1.8.4
Comment 8 mejiko 2015-04-11 05:14:28 EDT
No, This bug is not resolved, Quizilla contain non-free icons. (I checked version 1.8.6)


A (See description):

resolved. (Replaced)


B and C (See description): 

not resolved. (contain non-free logo)



Reference:

Section B (See description) Additional URI:

https://www.microsoft.com/en-us/legal/intellectualproperty/trademarks/usage/general.aspx

http://www.w3.org/Consortium/Legal/2002/trademark-license-20021231


Thanks.
Comment 9 mejiko 2015-08-05 05:12:46 EDT
How it this bug current status ? 
Is this bug is resolved ?

Thanks.
Comment 10 Tom "spot" Callaway 2015-09-14 15:59:30 EDT
The use of these specific icons is probably fair, because they're being used to refer to importing bookmarks from these other browsers.

Note You need to log in before you can comment on or make changes to this bug.