Bug 1131960 - rpm: malformed package selinux-policy-3.13.1-73.fc22.noarch
Summary: rpm: malformed package selinux-policy-3.13.1-73.fc22.noarch
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-20 11:59 UTC by Florian Weimer
Modified: 2014-08-28 10:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-28 10:56:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Florian Weimer 2014-08-20 11:59:39 UTC
While parsing the RPM package selinux-policy-3.13.1-73.fc22.noarch from rawhide, I noticed the following oddity.  The TRIGGERINDEX array has four elements, but the other trigger-related arrays have only two:

  HEADER:RPMVERSION (STRING): "4.12.0-beta1"
  HEADER:TRIGGERSCRIPTS (STRING_ARRAY):
  0: "selinuxenabled && semodule -nB\012exit 0"
  1: "rm -f /etc/selinux/*/modules/active/modules/sandbox.pp.disabled 2>/dev/null\012exit 0"
  HEADER:TRIGGERNAME (STRING_ARRAY):
  0: "pcre"
  1: "selinux-policy-targeted"
  HEADER:TRIGGERVERSION (STRING_ARRAY):
  0: ""
  1: "3.12.1-74"
  HEADER:TRIGGERFLAGS (INT32):
    0: 65536
    1: 262146
  HEADER:TRIGGERINDEX (INT32):
    0: 0
    1: 1
    2: 0
    3: 1

Comment 1 Panu Matilainen 2014-08-20 12:23:45 UTC
Fix being built into rpm-4.12.0-0.beta1.5.fc22 (and fc21). This is a double-facepalm as the regression is caused by another seemingly unrelated regression fix on Monday. Oh well...

Comment 2 Panu Matilainen 2014-08-21 08:11:43 UTC
FWIW, this can be easily detected with:
rpm --nosignature -qp --qf "[%{triggerindex} %{triggerflags}\n]" <package>

On affected packages you'll get an error about different sized arrays:
[pmatilai@localhost ~]$ rpm --nosignature -qp --qf "[%{triggerindex} %{triggerflags}\n]" /tmp/selinux-policy-3.13.1-73.fc22.noarch.rpm
error: incorrect format: array iterator used with different sized arrays
[pmatilai@localhost ~]$

Comment 3 Kevin Fenzi 2014-08-21 15:37:05 UTC
Affected f21 packages: 

 glibc-2.19.90-33.fc21.src.rpm
 nordugrid-arc-4.2.0-1.fc21.src.rpm
 nss-3.17.0-1.fc21.src.rpm
 rpcbind-0.2.1-1.0.fc21.src.rpm
 selinux-policy-3.13.1-73.fc21.src.rpm
 sendmail-8.14.9-4.fc21.src.rpm
 ser2net-2.9.1-3.fc21.src.rpm
 setroubleshoot-3.2.20-2.fc21.src.rpm
 sheepdog-0.3.0-8.fc21.src.rpm
 sks-1.1.5-4.fc21.src.rpm
 spamassassin-3.4.0-8.fc21.src.rpm
 spamass-milter-0.3.2-13.fc21.src.rpm
 speech-dispatcher-0.8-10.fc21.src.rpm
 squid-3.4.6-2.fc21.src.rpm
 squidGuard-1.4-21.fc21.src.rpm
 subversion-1.8.10-1.fc21.src.rpm
 sysklogd-1.5-16.fc21.src.rpm
 syslog-ng-3.5.6-2.fc21.src.rpm
 sysstat-11.0.0-2.fc21.src.rpm
 thttpd-2.25b-32.fc21.src.rpm
 ucarp-1.5.2-12.fc21.src.rpm
 unbound-1.4.22-4.fc21.src.rpm
 vnstat-1.11-20.fc21.src.rpm
 watchdog-5.13-11.fc21.src.rpm
 wpa_supplicant-2.0-10.fc21.src.rpm
 xl2tpd-1.3.6-5.fc21.src.rpm
 xrdp-0.6.1-4.fc21.src.rpm
 ypserv-2.32.1-3.fc21.src.rpm
 zoneminder-1.25.0-18.fc21.src.rpm

Waiting for rawhide to finish to check it.

Comment 4 Kevin Fenzi 2014-08-21 20:07:37 UTC
rawhide had one more package affected in it, certmonger. 

I've rebuilt all these now hopefully so we should be back on track... ;)

Comment 5 Panu Matilainen 2014-08-28 10:56:44 UTC
Guess we can close this now as per comment #4.


Note You need to log in before you can comment on or make changes to this bug.