Bug 113204 - LTC5734-Problem with multiple boot entries in /etc/zipl.conf
LTC5734-Problem with multiple boot entries in /etc/zipl.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: s390utils (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-09 12:44 EST by Mark Ver
Modified: 2015-03-04 20:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 23:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Ver 2004-01-09 12:44:56 EST
The following has be reported by IBM LTC:  
Problem with multiple boot entries in /etc/zipl.conf
Hardware Environment:
Type:                 2064
Model:                109

Software Environment:
VM00 Control Program: z/VM    4.4.0
Kernel: 2.4.21-6.EL #1 SMP Tue Dec 9 14:42:20 EST 2003 s390 s390 s390 
GNU/Linux
Zipl tool package: s390utils-1.2.1-4

Steps to Reproduce:
1. Add a new section into the /etc/zipl.conf file, example:
   [dumpdasd]
          dumpto=/dev/dasdb1
2. You run the new section and it works just fine:
   zipl dumpdasd
3. Now you try to rerun the default section again (for example if 
system is 
having trouble starting up and you want to restore the correct 
bootstrap after a 
crash):
   zipl

Actual Results:
When trying to run the default section, after having modified 
zipl.conf to 
include the additional (dumpdasd) section, the system spits back the 
message:
   Using config file '/etc/zipl.conf'
   Error: Section 'dumpdasd' cannot be included in menu 
'rh-automatic-menu'
The strange thing is that calling the added section seems to work just 
fine 
(in my case, I could actually get a dump with the target device).  
It's just 
processing for the default section that goes berserk.  The default 
section 
starts working again as soon as the added section is commented out 
again.

Expected Results:
You should be able to add other sections into the zipl.conf file, 
either for 
dump-dasd/dump-tape or other ipl sections if you have multiple kernel 
versions 
you need to deal with.

Additional Informatio
Comment 4 Jay Turner 2004-09-01 22:24:15 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-258.html
Comment 15 IBM Bug Proxy 2004-11-11 16:11:28 EST
----- Additional Comments From markver@us.ibm.com  2004-11-11 16:09 EDT -------
Tested this recently against "Taroon Update 4".
This issue seems to be fixed in that release.
For example:

[root@redhat1 boot]# uname -a
Linux redhat1.pdl.pok.ibm.com 2.4.21-22.EL #1 SMP Tue Oct 19 14:43:15 EDT 2004
s390 s390 s390 GNU/Linux
[root@redhat1 boot]# rpm -q s390utils
s390utils-1.2.4-5
[root@redhat1 boot]#
[root@redhat1 boot]# cat /etc/zipl.conf
[defaultboot]
default=linux
target=/boot/
[linux]
        image=/boot/vmlinuz-2.4.21-22.EL
        ramdisk=/boot/initrd-2.4.21-22.EL.img
        parameters="root=LABEL=/"
[dumpdasd]
        dumpto=/dev/dasde1
[root@redhat1 boot]#
[root@redhat1 boot]# zipl
Using config file '/etc/zipl.conf'
Building bootmap '/boot//bootmap'
Building menu 'rh-automatic-menu'
Adding #1: IPL section 'linux' (default)
Preparing boot device: dasdb (0201).
Done.
[root@redhat1 boot]# 
Comment 16 IBM Bug Proxy 2004-11-11 16:17:38 EST
----- Additional Comments From markver@us.ibm.com  2004-11-11 16:15 EDT -------
Since it seems fixed, marking bug as closed. 

Note You need to log in before you can comment on or make changes to this bug.