Bug 1132071 - [RFE] rhsm-debug system should also collect /etc/pki/product-default/
Summary: [RFE] rhsm-debug system should also collect /etc/pki/product-default/
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-08-20 15:25 UTC by John Sefler
Modified: 2014-10-14 07:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: rhsm-debug will now collect more directories. Reason: A new directory was added containing default product certificates. Result: rhsm-debug will now collect /etc/pki/product-default directory to help support personnel identify subscription problems.
Clone Of:
Environment:
Last Closed: 2014-10-14 07:48:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2014-08-20 15:25:54 UTC
Description of problem:
Once the implementation of bug 1123029 is complete, there will be a new directory provided by the implementation of bug 1080012 from which rhsm-debug system should collect additional data...
  /etc/pki/product-default/

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.12.12-1.el6.x86_64

How reproducible:


Steps to Reproduce:
Assuming the redhat-release-VARIANT package has not already provided /etc/pki/product-default/, then we can make one and populate it for the sake of testing this RFE bug...
[root@jsefler-6 ~]# mkdir /etc/pki/product-default/
[root@jsefler-6 ~]# cp /etc/pki/product/*.pem /etc/pki/product-default/
[root@jsefler-6 ~]# rhsm-debug system --no-archive 
Wrote: /tmp/rhsm-debug-system-20140820-298442
[root@jsefler-6 ~]# ls -l /tmp/rhsm-debug-system-20140820-298442/etc/pki/
total 12
drwxr-xr-x. 2 root root 4096 Aug 19 14:37 consumer
drwxr-xr-x. 2 root root 4096 Aug 19 14:47 entitlement
drwxr-xr-x. 2 root root 4096 Aug 19 09:24 product
[root@jsefler-6 ~]# 


Actual results:
above

Expected results:
there should also be a product-default directory with its contents included above 


Additional info:

Comment 2 John Sefler 2014-08-29 20:00:06 UTC
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.12.14-2.el6.x86_64


While registered...
[root@jsefler-6 ~]# ls -l /etc/pki/product*
/etc/pki/product:
total 4
-rw-r--r--. 1 root root 2167 Aug 29 14:33 69.pem

/etc/pki/product-default:
total 8
-rw-r--r--. 1 root root 2159 Aug 20 11:17 69.pem
-rw-r--r--. 1 root root 2208 Aug 29 14:57 70.pem
[root@jsefler-6 ~]# 
[root@jsefler-6 ~]# rhsm-debug system --no-archive
Wrote: /tmp/rhsm-debug-system-20140829-784175
[root@jsefler-6 ~]# 
[root@jsefler-6 ~]# 
[root@jsefler-6 ~]# ls -l /tmp/rhsm-debug-system-20140829-784175/etc/pki/product*
/tmp/rhsm-debug-system-20140829-784175/etc/pki/product:
total 4
-rw-r--r--. 1 root root 2167 Aug 29 14:33 69.pem

/tmp/rhsm-debug-system-20140829-784175/etc/pki/product-default:
total 8
-rw-r--r--. 1 root root 2159 Aug 20 11:17 69.pem
-rw-r--r--. 1 root root 2208 Aug 29 14:57 70.pem
[root@jsefler-6 ~]# 

VERIFIED: The rhsm-debug system tool now collects /etc/pki/product-default files

Comment 3 errata-xmlrpc 2014-10-14 07:48:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.