Bug 113244 - Upgrade on RH9 with Fedora perl RPM breaks packages
Summary: Upgrade on RH9 with Fedora perl RPM breaks packages
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-10 14:37 UTC by Armijn Hemel
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-02-17 19:58:46 UTC


Attachments (Terms of Use)

Description Armijn Hemel 2004-01-10 14:37:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20031219

Description of problem:
Upgrading the Perl interpreter on Red Hat 9 using the Fedora Core 1
RPM breaks a number of packages that depend on Perl, for example
vim-X11, vim-enhanced and xchat. The programs complained they couldn't
find libperl.so.

[root@vindaloo root]# ldd /usr/bin/vim
   libncurses.so.5 => /usr/lib/libncurses.so.5 (0x4002b000)
   libacl.so.1 => /lib/libacl.so.1 (0x4006a000)
   libgpm.so.1 => /usr/lib/libgpm.so.1 (0x40070000)
   libdl.so.2 => /lib/libdl.so.2 (0x40075000)
   libperl.so => not found
   [...]

The library used to be located at:          
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE/libperl.so

but after the upgrade it is at:
  /usr/lib/perl5/5.8.1/i386-linux-thread-multi/CORE/libperl.so

Adding the directory where libperl.so is located to /etc/ld.so.conf
and rerunning ldconfig fixed the problem, but I would expect that this
would have run during the upgrade of the package in the first place...


Version-Release number of selected component (if applicable):
5.8.1-92

How reproducible:
Always

Steps to Reproduce:
1.install Red Hat 9
2. grab Fedora Perl RPM
3. rpm -Uvh <fedora-perl-rpm>
    

Actual Results:  packages stopped working

Additional info:

Comment 1 Bart Martens 2004-01-29 17:04:46 UTC
I would not install fc1-rpms on a rh9. I suggest to close this bug as
"notabug".



Comment 2 Jeremy Portzer 2004-02-17 19:57:58 UTC
Agreed, this is definitely not a bug.  If you want the Perl from
Fedora Core 1, just upgrade the whole system to FC1.  You could also
try rebuilding Perl from source RPM, and you may need to rebuild other
packages that depend on a specific Perl version.  But it's not Red
Hat's problem.


Note You need to log in before you can comment on or make changes to this bug.