Bug 1132528 - Cannot delete an organisation
Summary: Cannot delete an organisation
Keywords:
Status: CLOSED DUPLICATE of bug 1100311
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Linux
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-21 13:59 UTC by cmilsted
Modified: 2017-02-23 21:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 14:09:17 UTC


Attachments (Terms of Use)

Description cmilsted 2014-08-21 13:59:58 UTC
Description of problem: The remove an Organisation dialogue does not appear.

NB I assume this is a duplicate of 761291 but that implies it was fixed in 6.0.1 so I have raised this to make sure.

Follow chapter 3.1.4 - Removing an Organisation from the user guide.


Version-Release number of selected component (if applicable): 6 beta (6.0.3)


How reproducible: every time - easily


Steps to Reproduce:
1.Create an organisation
2.Navigate to Administer - Organisations
3.Click the dropdown and all I see are nest and clone... no delete option

Actual results:as above - only get clone and nest.


Expected results: I should see a delete option as well as nest and clone


Additional info: 

I also tried this quickly on the command line and it failed:

[root@sat6 published]# hammer organization delete --id 3
Could not delete the organization:
  Error: The server does not support such operation.


Lst 50 lines of foreman log

  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.0ms)
Completed 200 OK in 1ms (Views: 0.9ms | ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.0ms)
Completed 200 OK in 1ms (Views: 1.0ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::OrganizationsController#index as application/json;version=2
  Parameters: {"api_version"=>"v2", "organization"=>{}}
Authorized user admin(Admin User)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/organizations/index.json.rabl within api/v2/layouts/index_layout (5.7ms)
Completed 200 OK in 312ms (Views: 23.3ms | ActiveRecord: 8.6ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.4ms)
Completed 200 OK in 22ms (Views: 22.1ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::OrganizationsController#index as application/json;version=2
  Parameters: {"page"=>"1", "sort"=>"", "per_page"=>"20", "api_version"=>"v2", "organization"=>{}}
Authorized user admin(Admin User)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/organizations/index.json.rabl within api/v2/layouts/index_layout (4.8ms)
Completed 200 OK in 46ms (Views: 6.0ms | ActiveRecord: 5.1ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.1ms)
Completed 200 OK in 1ms (Views: 1.2ms | ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.2ms)
Completed 200 OK in 195ms (Views: 194.9ms | ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.0ms)
Completed 200 OK in 1ms (Views: 1.2ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::OrganizationsController#index as application/json;version=2
  Parameters: {"api_version"=>"v2", "organization"=>{}}
Authorized user admin(Admin User)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/organizations/index.json.rabl within api/v2/layouts/index_layout (4.9ms)
Completed 200 OK in 49ms (Views: 6.4ms | ActiveRecord: 4.4ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.1ms)
Completed 200 OK in 2ms (Views: 1.4ms | ActiveRecord: 0.0ms)
Processing by Apipie::ApipiesController#apipie_checksum as JSON
  Parameters: {"apipy"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/app/views/apipie/apipies/apipie_checksum.json.erb (0.0ms)
Completed 200 OK in 1ms (Views: 1.0ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::OrganizationsController#index as application/json;version=2
  Parameters: {"api_version"=>"v2", "organization"=>{}}
Authorized user admin(Admin User)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/organizations/index.json.rabl within api/v2/layouts/index_layout (4.9ms)
Completed 200 OK in 47ms (Views: 6.4ms | ActiveRecord: 4.6ms)

Comment 1 RHEL Product and Program Management 2014-08-21 14:03:33 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-08-21 14:09:17 UTC
Will be enabled for GA I believe via bug #1100311.

*** This bug has been marked as a duplicate of bug 1100311 ***


Note You need to log in before you can comment on or make changes to this bug.