Bug 113265 - X server compatibility problems on Compaq Armada E500
X server compatibility problems on Compaq Armada E500
Status: CLOSED DUPLICATE of bug 115769
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 10:13 EST by Mattias Ellert
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2004-01-11 10:13:25 EST
Description of problem:
With the version of the X server that comes with FC1 (and RH9) there
are compatibility problems on Compaq Armada E500

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Every time

Problem 1:

Steps to Reproduce:
1. Start the computer
  
Actual results:
The computer takes a long time to start and flashes its LED's many
times indicating problems. And there are 22 lines in dmesg saying
"Keyboard timed out[1]".

Expected results:
Not so many flashes of the LED's and no "Keyboard timed out[1]" lines
in dmesg.

Problem 2:

Steps to Reproduce:
1. Connect a projector to the outlet on the back
2. Press Fn-F4 to send the screen to the projector

Actual results:
It does not work.

Expected results:
It should work.

Additional info:
After the following operation that downgrades part of the XFree86
package to the RH8 version both problems are cured:

wget -N
http://ftp.sunet.se/pub/Linux/distributions/redhat/updates/8.0/en/os/i386/XFree86-4.2.1-23.i386.rpm
 
rpm2cpio XFree86-4.2.1-23.i386.rpm | cpio -idm
 
mv /usr/X11R6/lib/modules /usr/X11R6/lib/modules.orig
cp -pr usr/X11R6/lib/modules /usr/X11R6/lib/modules
 
mv /usr/X11R6/bin/XFree86 /usr/X11R6/bin/XFree86.orig
cp -p usr/X11R6/bin/XFree86 /usr/X11R6/bin/XFree86
Comment 1 Mike A. Harris 2004-02-17 01:49:15 EST

*** This bug has been marked as a duplicate of 115769 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.