Bug 113270 - Incorrect sizing of starmath 10-pt no-break space (U+00A0)
Incorrect sizing of starmath 10-pt no-break space (U+00A0)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ttfonts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 14:25 EST by Frank Solensky
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-13 16:07:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Solensky 2004-01-11 14:25:22 EST
(should be against 'ttfonts', not included in component selection)

Description of problem:
No-break space (U+00A0) in starmath 10-pt font incorrect dimensions

Version-Release number of selected component (if applicable):
ttfonts 1.0.9

How reproducible:
Always

Steps to Reproduce:
1. Run Ximian Evolution
2. Select "fixed-width" font as preference
3. Compose an email message which includes consecutive spaces
  
Actual results:
Characters become misaligned as the blank string becomes longer

Expected results:
Alignment

Additional info:
http://bugzilla.ximian.com/show_bug.cgi?id=47713

Out-of-the-box setting for fixed width font is "Monospace 10".  Pango
picks "Luxi Mono 10" when displaying spaces, "StarMath 10" when
displaying U+00A0.  The dimensions of the U+00A0 character corresponds
to a 9-point font.
Comment 1 Frank Solensky 2004-01-11 14:32:22 EST
Moved to Red Hat 9 distro for better component match.
Comment 2 Frank Solensky 2004-01-12 08:48:23 EST
FWIW: ttfonts package appears to be carried over from 7.3 distro. 
Releases 8.0 and 9 don't include ttfonts-*.rpm but do include
ttfonts-[ja|ko|zh-CN|zh-TW] and ttfprint.  Should ttfonts be getting
included/updated as well?
Comment 3 Ngo Than 2004-01-13 16:07:10 EST
ttfonts was removed since RHL 8.0.

Note You need to log in before you can comment on or make changes to this bug.