Bug 113272 - Flash drive causes erratic behaviour
Flash drive causes erratic behaviour
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 14:45 EST by Need Real Name
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 18:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-01-11 14:45:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I'd like to apologise for the lack of information in the report. This
is due to me not knowing how to troubleshoot this. Any help would be
appreciated.

I have an Iomega USB Flash drive. It has a capacity of 128 MB.
I'm running a computer with USB 1.1, and the Flash drive is USB 1.1,
not 2.

When I mount the flash drive, using mount /dev/sda1 /mnt/flash, the
drive mounts fine. The drive is formatted as vfat.

The problem comes sometimes when I try to copy to the drive. Nothing
happens. No lights on the drive flash, and no feedback from cp.
Killing with kill or kill -9 on the cp, as normal user, or as root fails.
No entries are in /var/log/messages
I cannot unmount, or force an unmount of the drive as root.
A sync as root hangs.
lsof does show the copy.

Switching down to runlevel 1 still shows the non-root owned cp process.

How reproducible:
Sometimes
Comment 1 Bill Nottingham 2004-01-11 19:03:55 EST
This is a kernel issue.
Comment 2 Need Real Name 2004-03-16 07:18:18 EST
I still get this problem sometimes.
The problem is less likely to occur if I've recently formatted the 
flash drive.

poweroff seems possible if the machine is kept on for a time (an hour 
or more) after the problem.
Comment 3 Need Real Name 2004-04-14 18:27:19 EDT
I can't narrow down this one to produce a test case, so closing.

Note You need to log in before you can comment on or make changes to this bug.