Bug 1132733 - Untranslated language in "Missing language: {0}" window
Summary: Untranslated language in "Missing language: {0}" window
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Alexander Wels
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Keywords: Translation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-21 23:58 UTC by Yuko Katabami
Modified: 2016-04-20 01:39 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-04-20 01:39:41 UTC


Attachments (Terms of Use)
Unlocalized language names (174.84 KB, image/png)
2014-08-21 23:58 UTC, Yuko Katabami
no flags Details
Fixed translated for 'Missing language:{0}' (277.84 KB, image/png)
2015-08-19 09:27 UTC, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 34704 master MERGED engine: Missing language docs message Never

Description Yuko Katabami 2014-08-21 23:58:34 UTC
Created attachment 929385 [details]
Unlocalized language names

Description of problem:
The window which is displayed when a particular localized guide is not available contains unlocalized language names.

Version-Release number of selected component (if applicable): 3.5


How reproducible: 100%


Steps to Reproduce:
1. Login to Admin Portal with a locale other than en-US is selected.
2. Click "Guide"
3. Check the window title and contents

Actual results:
The name of the language is unlocalized 

Expected results:
It should be localized

Additional info:
Strings are not pushed to localization

Comment 1 Einav Cohen 2014-10-31 14:36:41 UTC
@Alexander: can we somehow take the locale-text from languages.properties (i.e. the file that we are using in order to display the locale names for the welcome-page locale drop-down, for example) in case it exists there?

[note attachment 929385 [details]: there problem seems to be in both the page title and the page body text]

Comment 2 Alexander Wels 2014-10-31 15:09:46 UTC
This should be a straight forward fix, the method that displays the language defaults to the default locale (which is based on the locale of the server, not the browser). And thus defaults to english, but you can pass in the locale to the display the language in. Should be very minor change.

Comment 3 Einav Cohen 2014-10-31 15:44:46 UTC
(In reply to Alexander Wels from comment #2)
> This should be a straight forward fix, the method that displays the language
> defaults to the default locale (which is based on the locale of the server,
> not the browser). And thus defaults to english, but you can pass in the
> locale to the display the language in. Should be very minor change.

thanks. Granting "devel_ack+". as this issue is not extremely severe, I am targeting it for 3.6

Comment 4 Lijun Li 2015-08-19 09:27:12 UTC
Created attachment 1064705 [details]
Fixed translated for 'Missing language:{0}'


Note You need to log in before you can comment on or make changes to this bug.