Bug 113276 - RFE: customizable -debuginfo package name
RFE: customizable -debuginfo package name
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 18:16 EST by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 06:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2004-01-11 18:16:11 EST
[This issue concerns redhat-rpm-config as well.]

Every now and then, there's a need to build packages that mangle the
resulting binary package name from a single unchanged source package,
based on some build time conditions.

Let's assume package (SRPM) foo.  Based on some options, the binary
rpm built from it can result in foo-bar or foo-quux being output.  But
the debuginfo package will always be named foo-debuginfo, making it
impossible to store the debuginfo packages resulting from foo-bar and
foo-quux in the same directory/repository/whatever (since they're
always the same, foo-debuginfo instead of foo-bar-debuginfo and
foo-quux-debuginfo).

Making the name of the debuginfo package customizable would help, for
example by defining this in foo.spec:

  %define debuginfo_name %{name}-bar-debuginfo

...could result in the debuginfo package "foo-bar-debuginfo".
Comment 1 Jeff Johnson 2004-01-12 06:19:44 EST
Rather than customize a rather arcane and fragile mechanism further
with Yet More Parameters, I'd rather see an explicit subpackage
used in spec files. That's all a -debuginfo package is.

See glibc for how to generate -debuginfo as an explicit sub-package.

Note You need to log in before you can comment on or make changes to this bug.