Bug 113284 - gnome-terminal crash when moving (copying?) files in mc
gnome-terminal crash when moving (copying?) files in mc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 21:08 EST by Leonard den Ottolander
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 14:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash dump mc in gnome-terminal comparing files (74.34 KB, text/plain)
2004-02-13 14:41 EST, Leonard den Ottolander
no flags Details

  None (edit)
Description Leonard den Ottolander 2004-01-11 21:08:14 EST
Description of problem:

ssh session to SUSE Linux 9.0 server. Midnight commander running on
server (not in local terminal). Gnome-terminal crashes during mc file
copy.

I have seen a crash in gnome-terminal about a week ago during an rsync
to the same server. Not sure if that was from an mc session, but if it
was it was mc on the client then.

By the way, how do I set a ulimit in gnome-session (can't use
.bashrc)? I guess core dumps might be useful here ;).


Version-Release number of selected component (if applicable):

Local machine, FC1:
gnome-terminal-2.4.0.1-1
openssh-3.6.1p2-19
openssh-clients-3.6.1p2-19

Remote machine, SUSE 9.0:
openssh-3.7.1p2-18
mc-4.6.0-155


How reproducible:

Intermittent, but second time in about a week.
Comment 1 Leonard den Ottolander 2004-01-11 21:21:47 EST
Funny. Copying a file to the same directory with F5 (copy to *.000
etc) from inside the SUSE mc session decreases the local FC1
gnome-terminal size with one line.
Comment 2 Leonard den Ottolander 2004-01-15 08:26:06 EST
The funny resize behaviour has disappeared since the latest upgrades
(kernel?, glibc??). Any idea what changed it?

Still remains that whatever changed, the segfault was in
gnome-terminal. It might not occur any more now, but it is not fixed
in situ.
Comment 3 Leonard den Ottolander 2004-02-06 16:39:12 EST
Again a crash happened when moving a file from one panel to another
using the midnight commander. Still seeing the resize behaviour on
copying or moving of files in mc inside a gnome-terminal.

In this case neither of the four tabs contained an SSH session, so
this is entirely a local problem.

The title of the terminal changed to contain "funny" characters.

Debugging Information:

Backtrace was generated from '/usr/bin/gnome-terminal'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[Thread
debugging using libthread_db enabled]
[New Thread -1084484960 (LWP 4763)]

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x00562c32 in _dl_sysinfo_int80 ()
   from /lib/ld-linux.so.2
#0  0x00562c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0080eb03 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x035157f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00dcb108 in pango_layout_iter_get_char_extents ()
   from /usr/lib/libpango-1.0.so.0
#5  0x0807b3ef in eel_pango_layout_set_font_desc_from_string ()
#6  0x0807b6fd in eel_pango_layout_set_font_desc_from_string ()
#7  0x0807ba8e in eel_pango_layout_set_text_ellipsized ()
#8  0x0807adac in eel_ellipsizing_label_set_text ()
#9  0x00c6abae in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
#10 0x00c58007 in g_cclosure_new_swap () from
/usr/lib/libgobject-2.0.so.0
#11 0x00c57cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#12 0x00c6949d in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
#13 0x00c68c36 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0

Thread 1 (Thread -1084484960 (LWP 4763)):
#0  0x00562c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0080eb03 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x035157f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00dcb108 in pango_layout_iter_get_char_extents ()
   from /usr/lib/libpango-1.0.so.0
No symbol table info available.
#5  0x0807b3ef in eel_pango_layout_set_font_desc_from_string ()
No symbol table info available.
#6  0x0807b6fd in eel_pango_layout_set_font_desc_from_string ()
No symbol table info available.
#7  0x0807ba8e in eel_pango_layout_set_text_ellipsized ()
No symbol table info available.
#8  0x0807adac in eel_ellipsizing_label_set_text ()
No symbol table info available.
#9  0x00c6abae in g_cclosure_marshal_VOID__BOXED ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x00c58007 in g_cclosure_new_swap () from
/usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x00c57cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x00c6949d in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
No symbol table info available.
#13 0x00c68c36 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
No symbol table info available.
#0  0x00562c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
Comment 4 Leonard den Ottolander 2004-02-06 16:40:35 EST
Subject change as the remote session now seems irrelevant.
Comment 5 Leonard den Ottolander 2004-02-07 08:06:33 EST
Looking at the back trace bug #104284 might be the same issue, but
more reproducible.
Comment 6 Leonard den Ottolander 2004-02-10 17:24:25 EST
Latest pango upgrade seems to solve the funny resize behaviour, but
now I see a mangled menu title after copying a file with mc.
Comment 7 Leonard den Ottolander 2004-02-10 17:29:44 EST
Comment #5 seems to be a mistake. This is probably not the same issue.

Moving to component pango, as I assume it belongs there.
Comment 8 Leonard den Ottolander 2004-02-10 17:54:17 EST
The funny resize behaviour did *not* dissappear. Only it requires more
than 1 tab to be opened to happen.
Comment 9 Leonard den Ottolander 2004-02-13 14:40:26 EST
Comparing files using mc, directory against rpm content. Crashed again.

pango_layout_iter_get_char_extents

again.
Comment 10 Leonard den Ottolander 2004-02-13 14:41:23 EST
Created attachment 97660 [details]
Crash dump mc in gnome-terminal comparing files
Comment 11 Leonard den Ottolander 2004-03-01 12:02:35 EST
The crash appears in g_utf8_next_char(). This probably means
gnome-terminal doesn't pass proper UTF-8 to pango.
Comment 12 Owen Taylor 2004-03-01 12:10:53 EST
Well, not exactly that since pango_layout_set_text() does validate 
the text.

This is same as:

 http://bugzilla.gnome.org/show_bug.cgi?id=130108
Comment 13 Leonard den Ottolander 2004-03-01 12:37:39 EST
I cannot always reproduce this, but here is what I do:

open gnome-terminal
open more than 1 tab
resize to 80x40
start mc
copy or move files (it might help if one of the mc panels contains
empty lines)
Comment 14 Leonard den Ottolander 2004-03-01 12:39:12 EST
Oops. Probably also important: Set your locale to en_US.ISO-8859-15.
Comment 15 Kir Kolyshkin 2004-03-01 16:08:32 EST
Seen the same bug several times on gnome-terminal-2.5.1, mc-4.6.0,
pango-1.2.5-1.1. My locale is ru_RU.KOI8-R. I was unable to get the
coredump, but this is a description of what I'm doing:

1. gnome-terminal have several tabs opened;
2. mc is running in current tab;
3. i do some operation in mc (change dir, copy files, etc.);
4. current tab suddenly showing some weird title (garbage most
consisting of pseudographics characters);
5. gnome-terminal crashes

Hope this will help.
Comment 16 Warren Togami 2004-04-13 23:59:39 EDT
jakub, noticed anything like this in your daily usage of mc?
Comment 17 Jakub Jelinek 2004-04-14 02:13:38 EDT
I use mc daily, but don't use X that often, so the answer is no.
Comment 18 Leonard den Ottolander 2004-04-14 08:21:57 EDT
Upstream URL is http://bugzilla.gnome.org/show_bug.cgi?id=89541

Temporary update to pango-1.3.3-1 and glib2 2.3.3-1 did not (entirely)
solve this problem (see
http://www.redhat.com/archives/fedora-devel-list/2004-March/msg00130.html).

(No idea why I changed to gnome-terminal again, moving back to pango
and Owen.)
Comment 19 Leonard den Ottolander 2004-05-20 06:31:03 EDT
Easiest way to reproduce this is the method mentioned in comment #9:
Enter an rpm in mc, then compare (F9; C; C -> boom).
Comment 20 Owen Taylor 2004-09-02 14:21:14 EDT
All the Pango issues here have long since been fixed. Issues with
mc setting the window title to strange values should be filed
separately, if they still exist.

Note You need to log in before you can comment on or make changes to this bug.