Bug 113286 - Tomcat has exceptions when run
Tomcat has exceptions when run
Status: CLOSED NOTABUG
Product: Red Hat Application Server Public Beta
Classification: Retired
Component: tomcat (Show other bugs)
1.0-beta1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-11 21:48 EST by Need Real Name
Modified: 2007-04-18 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-15 05:34:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tomcat logfile (92.85 KB, text/plain)
2004-01-11 21:50 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2004-01-11 21:48:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; YComp 
5.0.0.0; .NET CLR 1.0.3705)

Description of problem:
When I start Tomcat, 'service tomcat start'., Tomcat starts normally. 
After Tomcat has started, a null pointer execption occurs. There are 
a lot of funny characters in the log file.

Version-Release number of selected component (if applicable):
tomcat-4.1.27-8

How reproducible:
Always

Steps to Reproduce:
1.Type 'service tomcat start'
2.Type 'tail -f /usr/share/tomcat/logs/tomcat.out'
3.Go to http://ashcraftfamily.net:8080
The link is internal ONLY.
    

Actual Results:  A strange log entry appeared.

Expected Results:  Tomcat should have started normally.

Additional info:

It's a Compaq Proliant 850R, Dual Processor.
Comment 1 Need Real Name 2004-01-11 21:50:23 EST
Created attachment 96888 [details]
Tomcat logfile

Hope this helps
Comment 2 Gary Benson 2004-01-13 11:32:06 EST
Looks like you're pointing your browser at the AJP port.  If you want
Tomcat to serve HTTP directly then you need to uncomment the connector
labelled "non-SSL Coyote HTTP/1.1 Connector" in
/etc/tomcat/server.xml.  If you want to access Tomcat via AJP
(recommended, and the default) then you need to configure httpd with
mod_jk2 and access Tomcat through that. Configuring mod_jk2 basically
comprises installing the mod_jk2 rpm, adding a pair of lines to
/etc/httpd/conf/workers2.properties for each application, and
reloading httpd (service httpd reload).  The relevant lines for the
examples webapp are:
===START===
[uri:/examples/*]
info=Map the whole webapp
===END===
Let me know how you get on.
Comment 3 Need Real Name 2004-01-14 21:21:16 EST
Thanks! I have another problem now though. I will file another bug, as
it is with CCM/CMS

Note You need to log in before you can comment on or make changes to this bug.