Bug 113294 - [wish] support for a "cycle_workspaces" keybinding
[wish] support for a "cycle_workspaces" keybinding
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-12 05:48 EST by Mihai Bazon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 16:59:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
provides cycle_workspaces functionality (16.73 KB, patch)
2004-01-12 05:50 EST, Mihai Bazon
no flags Details | Diff

  None (edit)
Description Mihai Bazon 2004-01-12 05:48:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)
Gecko/20040104 Firebird/0.7+

Description of problem:
This is not a bug but a feature request.

I wish Metacity had some quick way to go to the previous workspace,
sort of IceWM's "KeySysWorkspaceLast" keybinding.  I wished it so much
that I actually made a patch which allows some sort of "workspace
history" (a list of configurable size that remembers the most recently
used workspaces) along with keybindings to quickly jump through them.

The keybindings are "disabled" by default so they can't harm anyone
not interested in such functionality.

Could this (or a similar patch) be included in the distribution? ;-)

Version-Release number of selected component (if applicable):
metacity-2.6.3-1

How reproducible:
Always

Steps to Reproduce:
n/a

Additional info:
Comment 1 Mihai Bazon 2004-01-12 05:50:04 EST
Created attachment 96891 [details]
provides cycle_workspaces functionality

patch made against the sources found in metacity-2.6.3-1.src.rpm of Fedora Core
1
Comment 2 Havoc Pennington 2004-05-25 16:59:00 EDT
I think this adds too much complexity/confusion, though I appreciate
the work to create the patch.

Note You need to log in before you can comment on or make changes to this bug.