Bug 1133146 - builder.py --update-tag-package-list is not Python 2.6 compatible
Summary: builder.py --update-tag-package-list is not Python 2.6 compatible
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: rel-eng
Version: 2.4.1
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-22 21:36 UTC by Randy Barlow
Modified: 2015-02-28 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:16:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 497 None None None Never

Description Randy Barlow 2014-08-22 21:36:17 UTC
Description of problem:
builder.py seems to be using a feature that was new in Python 2.7:

$ ./builder.py --update-tag-package-list 2.4 beta
Traceback (most recent call last):
  File "./builder.py", line 531, in <module>
    add_packages_to_tag(build_tag)
  File "./builder.py", line 482, in add_packages_to_tag
    result = str(subprocess.check_output(command, shell=True))
AttributeError: 'module' object has no attribute 'check_output'

Version-Release number of selected component (if applicable):
2.4.1-0.2.alpha

How reproducible:
very

Steps to Reproduce:
1. ./builder.py --update-tag-package-list 2.4 beta

Actual results:
Traceback!

Expected results:
Tags should have been updated.

Additional info:

Comment 1 Brian Bouterse 2015-02-28 22:16:22 UTC
Moved to https://pulp.plan.io/issues/497


Note You need to log in before you can comment on or make changes to this bug.