Bug 1133166 - Anaconda makes screen flicker randomly and often
Summary: Anaconda makes screen flicker randomly and often
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell   
(Show other bugs)
Version: 21
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1134564 1134683 (view as bug list)
Depends On:
Blocks: F21AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-08-23 01:23 UTC by Diogo Campos
Modified: 2014-08-28 12:48 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-27 04:12:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen flickering (4.81 MB, video/ogg)
2014-08-23 05:10 UTC, Chandan Kumar
no flags Details

Description Diogo Campos 2014-08-23 01:23:06 UTC
Description of problem: when trying to install Fedora 21 (ISO mentioned below), after clicking the "I accept my fate" button, the screen starts blinking frequently and randomly. I accuse Anaconda because can not reproduce the effect with other programs (in a quick test - which included playing a Youtube video in full screen, in Firefox).


Version-Release number of selected component (if applicable):
Anaconda = 21.48.2-1.fc21
ISO = Fedora Live Workstation 21 - Alpha TC3.


How reproducible: Always. Just in anaconda, after pressing "I accept my fate" button, no matter the language choosed (tested with "Portuguese - BR" and "English - US", at least).


Steps to Reproduce:
1. boot ISO mentioned above.
2. click "Install".
3. select a language, click "next", and click "I accept my fate" button.

Actual results: Screen flickering.


Expected results: No flickering.


Additional info: Tested in a notebook without main screen, connected in a external monitor via VGA port. GPU = "Intel HD Graphics" (Sandy Bridge - "Pentium B950"). Reproducible even without "video=LVDS-1:d" boot option.

Comment 1 Chandan Kumar 2014-08-23 05:09:32 UTC
I have got the same screen flickering issue with the same iso image. i have tested it in a virtual machine (libvirt) having f20 gnome as a base os with 1 cpu, 1024 ram and 20 gb disk space for installation.

Comment 2 Chandan Kumar 2014-08-23 05:10:29 UTC
Created attachment 929857 [details]
Screen flickering

Comment 3 Amit Shah 2014-08-23 05:49:25 UTC
The flickering started for me on clicking on a dropdown box; before that, the screen was stable.

In my case, the dropdown box I selected was in the Date and Time screen and clicked on the region/city dropdowns.

Comment 4 Ankur Sinha (FranciscoD) 2014-08-24 02:28:51 UTC
Hello,

The flickering was quite random but a lot in my case. It was almost difficult to keep looking at the screen. Complete machine install on two machines. 

anaconda-21.48.2-1.fc21.x86_64


Video: https://db.tt/Zc5amiN3

Thanks,
Warm regards,
Ankur

Comment 5 satellitgo 2014-08-24 03:01:30 UTC
Also seen in workstation live TC3 and KDE live TC3 installs to bare metal
see BZ 1103496 comments 30

Comment 6 Kamil Páral 2014-08-25 14:42:47 UTC
I see this with nightly Fedora-Live-Workstation-x86_64-21-20140824.iso. I'm going to propose this as an Alpha blocker, even though we obviously have no criterion for this. Everything technically works, but it's so uncomfortable (at least for me, I guess not just me), that it makes operating anaconda really difficult.

Comment 7 Adam Williamson 2014-08-25 14:43:46 UTC
Yeah, I've seen this in live installs too. Not sure I'd call it a blocker as it's not so terrible to work around, but it is kinda annoying and does look bad.

Comment 8 Kamil Páral 2014-08-25 14:56:21 UTC
Some additional information:
Blinking starts on 42% of installation for me, regardless whether I entered the rootpw/user creation dialog. It switches between the wallpaper and anaconda. If you go to overview mode in Gnome, it does not blink. If you return back, it blinks again.

The image link is here:
https://kojipkgs.fedoraproject.org//work/tasks/4637/7444637/Fedora-Live-Workstation-x86_64-21-20140824.iso

For older images, I think I might have seen the blinking even in the main hub, not just during installation, but I'm not really sure. But the above reports seem to confirm it.

Comment 9 David Shea 2014-08-25 21:39:38 UTC
As far as I can tell this only happens in gnome-shell, and it seems to be related to anaconda running in fullscreen (i.e., gtk_window_fullscreen) mode. The gnome-shell process takes up as much CPU as it can get when all of this flickering business starts. Reassigning. Help us, gnome-shell, you're our only hope.

Comment 10 Kamil Páral 2014-08-26 15:59:36 UTC
A few more details from #fedora-desktop conversation with drago01:

<drago01> kparal: ok can you do "alt-f2" "lg" enter "Meta.disable_unredirect_for_screen(global.screen);" and then try anaconda
<kparal> drago01: if I disable unredirect, it stops flickering. if I enable it again, it starts flickering again. happens immediately

<drago01> kparal: ok, one more thing can you try to get a backtrace while the flicker is ongoing?
<kparal> drago01: http://paste.fedoraproject.org/128639/
<kparal> drago01: and a second attempt here, in case it's different: http://paste.fedoraproject.org/128642/
<drago01> kparal: hmm ok both aren't telling much just "drawing stuff"

<kparal> drago01: another interesting thing is this: anaconda flickering -> run terminal -> switch back and forth between anaconda and terminal -> close terminal -> you see desktop (because anaconda window got minimized automatically) -> switch back to anaconda -> it no longer flickers
<drago01> kparal: as for your observation that means that anaconda does not get unredirected anymore ... actually it shouldn't but apperently it does 100 full window damages in a row and thus gets detected as a "game"

<mclasen> I've seen similar flicker with who-t's user study app
<mclasen> drago01: can you see this ? http://libinput-whot.rhcloud.com/
<mclasen> or go straight here, I guess: http://copr.fedoraproject.org/coprs/whot/libinput-userstudy/
<drago01> mclasen: ah nice reproduces
<drago01> mclasen: and the window isn't sized corrected

<drago01> kparal: can you confirm that it does *not* happen when you run just mutter (no gnome-shell) i.e "mutter --replace " in a terminal
<kparal> drago01: so, do you want the short or the complicated answer?
<drago01> kparal: both ;)
<kparal> the screen is not flickering at all during installation
<kparal> however, I noticed that if I hover my mouse over some of the "user settings" icon to let a popup text appear and then move it around to let the popup text disappear, the screen flashes briefly, once or twice
<kparal> again, I see the background, lime color this time
<kparal> this flashing right after popup disappears does not happen in the beginning of the installation, but it does happen at the end of the installation
<kparal> which matches screen flickering issues under gnome-shell - that also happens only in the second half of the installation
<kparal> not sure whether it is related or not
<drago01> kparal: ok

Comment 11 drago01 2014-08-26 16:33:49 UTC
Can someone please test with this scratch build (once its done): http://koji.fedoraproject.org/koji/taskinfo?taskID=7453921 

I didn't test with anaconda but could reproduce the bug with libinput-userstudy; the bug looks very similar so that fix should work for anaconda too.

Comment 12 drago01 2014-08-26 17:04:32 UTC
OK I have built a proper package http://koji.fedoraproject.org/koji/taskinfo?taskID=7454039 with the upstream version of the patch (it does the same).

Comment 13 David Shea 2014-08-26 18:19:39 UTC
I think it worked. I updated mutter on Fedora-Live-Workstation-x86_64-21-20140824.iso with the package from comment 12 and restarted gdm, and the install looks fine now. Thanks!

Comment 14 drago01 2014-08-26 20:27:11 UTC
(In reply to David Shea from comment #13)
> I think it worked. I updated mutter on
> Fedora-Live-Workstation-x86_64-21-20140824.iso with the package from comment
> 12 and restarted gdm, and the install looks fine now. Thanks!

OK, thanks for testing. I guess we can close this one now?

Comment 15 Adam Williamson 2014-08-27 04:12:04 UTC
Package is tagged for F21, so for now yeah, we'll re-open if it turns out not to be fixed.

Comment 16 David Shea 2014-08-27 19:26:08 UTC
*** Bug 1134564 has been marked as a duplicate of this bug. ***

Comment 17 Kamil Páral 2014-08-28 11:20:11 UTC
Yesterday nightly contains the new mutter and anaconda no longer flickers. Thanks, drago01!

Comment 18 David Shea 2014-08-28 12:48:27 UTC
*** Bug 1134683 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.