Bug 1133180 - [RFE] - RHEVH should always require the minimum partition sizes in the TUI which are named in the documentation
Summary: [RFE] - RHEVH should always require the minimum partition sizes in the TUI wh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1214270 1242441 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-23 05:13 UTC by Ulhas Surse
Modified: 2019-04-28 09:21 UTC (History)
15 users (show)

Fixed In Version: ovirt-node-3.3.0-0.4.20150906git14a6024.el7ev
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:13:27 UTC
oVirt Team: Node
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1208041 urgent CLOSED TUI hosted-engine-setup process is unexpected terminated when boot rhevm-appliance.ova because of ENOSPC in the tempdir 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 40638 master MERGED Add a minimum data size Never
oVirt gerrit 40673 master MERGED Add a warning about the appliance if the data size is too small Never

Internal Links: 1208041

Description Ulhas Surse 2014-08-23 05:13:42 UTC
Description of problem:
In the installation of RHEV-H, when data partition is set to 0 MB, installation completes successfully but the registration does not happen even after providing ovirt engine server IP with proper network configuration.

Version-Release number of selected component (if applicable):
Reproduced with RHEV-H-20140725.0.ISO image from customer portal.

How reproducible:
Always

Steps to Reproduce:
1. Install RHEV-H 
2. On partitioning scheme, set data partition as 0.

Actual results:
RHEV-H does not register to RHEV-M

Expected results:
Error/ Message should be displays as 0 is not allowed as recommended size or valid input something like that.

Additional info:

Comment 2 Fabian Deutsch 2014-09-03 13:56:29 UTC
Allon, is there a recommended minimum size for the /data mountpoint?

Comment 3 Allon Mureinik 2014-09-11 15:39:04 UTC
(In reply to Fabian Deutsch from comment #2)
> Allon, is there a recommended minimum size for the /data mountpoint?
I'd say a minimum of 10GB.

Comment 4 Yaning Wang 2014-09-12 08:13:04 UTC
Can reproduce

Version-Release number of selected component

RHEV-H 6.5-20140821.1.el6ev
ovirt-node-3.0.1-18.el6.14

RHEVM 3.4.2-1.1.el6ev

Steps to Reproduce:
1. Install RHEV-H 
2. On partitioning scheme, set data partition as 0.

Actual results:
RHEV-H does not register to RHEV-M

Comment 5 Ying Cui 2014-09-12 08:42:30 UTC
Ago we discussed data partition size issue in the following two bugs.
https://bugzilla.redhat.com/show_bug.cgi?id=868785#c2
https://bugzilla.redhat.com/show_bug.cgi?id=1026138

Here additional testing is 'Adding rhevh host from RHEVM portal successful when data partition as 0'

Comment 6 Ying Cui 2014-12-10 09:49:47 UTC
Customer ticket attached on this bug, so QE consider to get this fix in rhev 3.5.0.

Comment 7 Fabian Deutsch 2015-04-13 13:29:38 UTC
We should require the minimum size of 10GB for the data partition (as mentioned in comment 3) during the TUI installation.

Comment 8 Ying Cui 2015-05-07 02:55:13 UTC
For the long term, let's reconsider the minimum size of data partition because of self hosted-engine on rhevh, here we need to provide enough space(50G+) for /data/hosted_engine_temp for ovirt_hosted_engine_setup.vm.boot_disk. See bug 1208041.

Comment 9 Fabian Deutsch 2015-05-07 14:35:20 UTC
(In reply to Ying Cui from comment #8)
> For the long term, let's reconsider the minimum size of data partition
> because of self hosted-engine on rhevh, here we need to provide enough
> space(50G+) for /data/hosted_engine_temp for
> ovirt_hosted_engine_setup.vm.boot_disk. See bug 1208041.

We should stick to what we recommend in the docs: https://access.redhat.com/articles/1168703
256MB min data size.
We can add a text to the guide to highlight that the minimum data size needs to be at least 50Gb in case that HE is used.

In any case the HE setup should fail if the min data size is not met - but this is covered in bug 1208041.

Comment 10 Ying Cui 2015-05-07 15:42:46 UTC
(In reply to Fabian Deutsch from comment #9)
> (In reply to Ying Cui from comment #8)
> > For the long term, let's reconsider the minimum size of data partition
> > because of self hosted-engine on rhevh, here we need to provide enough
> > space(50G+) for /data/hosted_engine_temp for
> > ovirt_hosted_engine_setup.vm.boot_disk. See bug 1208041.
> 
> We should stick to what we recommend in the docs:
> https://access.redhat.com/articles/1168703
> 256MB min data size.

After this bug in rhev 3.6.0 phase, the 10GB is minimum size for /data in rhevh.

> We can add a text to the guide to highlight that the minimum data size needs
> to be at least 50Gb in case that HE is used.

document that can be acceptable. Thanks.

> 
> In any case the HE setup should fail if the min data size is not met - but
> this is covered in bug 1208041.

Comment 11 Fabian Deutsch 2015-05-20 12:51:04 UTC
*** Bug 1214270 has been marked as a duplicate of this bug. ***

Comment 12 Fabian Deutsch 2015-07-13 12:02:18 UTC
*** Bug 1242441 has been marked as a duplicate of this bug. ***

Comment 13 cshao 2015-10-08 08:11:29 UTC
Test version:
rhev-hypervisor7-7.2-20150928.0
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch

Test steps:
1. Boot from PXE
2. Install RHEV-H via TUI
3. Enter storage volumes page
4. uncheck "fill disk with data partition" option.
5. deleted data partition size.

Test result:
It pop-up: The filed must contain a number in the bounds (10240, ~)
The 10GB is minimum size for /data in rhevh.

And according #c9 & 10, so the bug is fixed, change bug status to VERIFIED.

Comment 14 Lucy Bopf 2016-02-19 10:28:23 UTC
Moving 'requires_doc_text' to '-', as this bug is verified and no longer needs to be documented as a known issue.

Comment 16 errata-xmlrpc 2016-03-09 14:13:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.