Bug 1133346 - XA Recovery scans can stall JBoss startup
Summary: XA Recovery scans can stall JBoss startup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR12
: EAP 6.4.0
Assignee: Michael
QA Contact: Ondrej Chaloupka
URL:
Whiteboard:
Depends On: 1143956
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-24 22:32 UTC by James Livingston
Modified: 2019-08-19 12:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In JBoss EAP 6, transaction recovery operates by asking resources for their view of in-doubt transaction branches using "RecoveryHelpers" provided by other subsystems. When a deployment registers one of these helpers, a lock is taken. The same lock is acquired when recovering a resource. If the resource is slow to complete a recovery request, then the subsystem deployment (which is waiting for the lock) is similarly delayed. In this release the contention on the lock is broken and subsystems deploy as expected.
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 376403 None None None Never
Red Hat One Jira Issue Tracker JBTM-2242 Major Closed Misbehaving XAResources may delay deployments 2019-08-01 11:06:27 UTC

Description James Livingston 2014-08-24 22:32:36 UTC
Recovery scans can delay subsystem deployments because of contention on the lock XARecoveryModule._xaResourceRecoveryHelpers. If recovery takes a long time, for example caused by Database performance or connectivity issues, it can stall JBoss startup.

Comment 1 tom.jenkinson 2014-09-02 11:19:03 UTC
fixed in community project, awaiting release

Comment 2 tom.jenkinson 2014-12-05 12:40:35 UTC
Went into 4.17.23

Comment 3 Ondrej Chaloupka 2014-12-10 08:12:54 UTC
Verified. The deployment is not blocked by periodic recovery as described in jira.
This fix is available from DR3.

Comment 4 JBoss JIRA Server 2014-12-11 15:53:59 UTC
Tom Jenkinson <tom.jenkinson@redhat.com> updated the status of jira JBTM-2242 to Closed


Note You need to log in before you can comment on or make changes to this bug.