Bug 1133582 - broken command substitution while stdout closed
Summary: broken command substitution while stdout closed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks: 1133586
TreeView+ depends on / blocked
 
Reported: 2014-08-25 13:49 UTC by Filip Krska
Modified: 2018-12-09 18:26 UTC (History)
4 users (show)

Fixed In Version: ksh-20120801-19.el6
Doc Type: Bug Fix
Doc Text:
Previously, ksh reused low file descriptor numbers, when any of them was closed previously, but did not handle them correctly when they were not used for standard input, output or error output. As a result, when any of stdin, stdout or stderr was closed and its file descriptor was reused in command substitution, the output from command substitution was empty. The code was updated to not reuse those low file descriptors for command substitution. Command substitution now works correctly even if any of stdin, stdout or stderr is closed.
Clone Of:
: 1133585 1133586 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:04:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to fix this (1.59 KB, patch)
2014-08-26 13:51 UTC, Michal Hlavinka
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1381 0 normal SHIPPED_LIVE ksh bug fix update 2014-10-14 01:28:24 UTC

Description Filip Krska 2014-08-25 13:49:42 UTC
Description of problem:

The behavior regarding command substitution while stdout closed has changed between ksh-20120801 and ksh-20100621

Version-Release number of selected component (if applicable):

ksh-20120801-10.el6_5.8.x86_64

How reproducible:

Always

Steps to Reproduce:
1.
# ksh -c 'a=`cd;pwd`;echo $a>/tmp/a' >&-;cat /tmp/a

2.
3.

Actual results:

no output

Expected results:

/root

Additional info:

Comment 2 Michal Hlavinka 2014-08-26 13:51:59 UTC
Created attachment 931003 [details]
patch to fix this

Comment 8 errata-xmlrpc 2014-10-14 07:04:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1381.html


Note You need to log in before you can comment on or make changes to this bug.