Bug 1133590 - Unable to login in to 'Red Hat Access' in IE
Summary: Unable to login in to 'Red Hat Access' in IE
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Red Hat Access
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: CR02
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-11
TreeView+ depends on / blocked
 
Reported: 2014-08-25 13:59 UTC by Jeeva Kandasamy
Modified: 2016-05-24 17:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Known bugs with Microsoft Internet Explorer Cross Origin Resource Sharing (CORS) support prevented users logging onto JON through a HTTP connection, and then following HTTPS links in the iFrame containing the Red Hat Access plug-in. There is no workaround to this issue other than not using Microsoft Internet Explorer to access Red Hat Access through JBoss ON.
Clone Of:
Environment:
[Release_Notes] Entry created in the Release Notes.
Last Closed: 2014-12-11 14:02:11 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2296061 None None None 2016-05-18 20:59:19 UTC

Description Jeeva Kandasamy 2014-08-25 13:59:36 UTC
Description of problem:
Unable to login in to 'Red Hat Access' in IE

Version-Release number of selected component (if applicable):
JBoss Operations Network	
Version : 3.3.0.ER01
Build Number : 23b3476:f3aa7e7
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser Version: IE 9 and IE 11

How reproducible:
always

Steps to Reproduce:
1. Login in to JON 3.3
2. Click on 'Red Hat Access->Support->Open Case'
3. Click on 'Log In'
4. Enter Redhat login and username, Press 'Sign in', no status.

Actual results:
Unable to login in to Red Hat Access account

Expected results:
Should be log in

Comment 1 Jirka Kremser 2014-08-28 10:11:02 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/33a5bbe15
time:    2014-08-28 12:08:47 +0200
commit:  33a5bbe154f0eb0def4d48497431315e9528422f
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1133590, BZ 1133909] - Upgrading the version of Red Hat Access
         angular app, where the issues are already fixed.

Comment 2 Jirka Kremser 2014-08-29 11:58:25 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/1e94f22fa
time:    2014-08-29 13:56:56 +0200
commit:  1e94f22faf3048c2f30d82cc909b9d3785c65eb0
author:  Jirka Kremser - jkremser@redhat.com
message: [BZ 1133590, BZ 1133909] - Upgrading the version of Red Hat Access
         angular app, where the issues are already fixed.

         (cherry picked from commit
         33a5bbe154f0eb0def4d48497431315e9528422f) Signed-off-by: Jirka
         Kremser <jkremser@redhat.com>

Comment 3 Simeon Pinder 2014-09-03 20:31:23 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=381194

Comment 4 Jeeva Kandasamy 2014-09-10 11:56:27 UTC
Version:
JBoss Operations Network	
Version : 3.3.0.ER02
Build Number : 4fbb183:7da54e2
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: IE 11

Still I can see this issue.

Comment 6 Simeon Pinder 2014-09-29 08:12:29 UTC
Moving into ER05 as didn't make the ER04 cut.

Comment 8 Simeon Pinder 2014-10-21 20:24:05 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 9 Armine Hovsepyan 2014-10-23 08:44:56 UTC
issue is still visible in IE11 (IE9 compatible view as well)

Comment 12 Libor Zoubek 2014-10-24 14:48:26 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/dc988e871
time:    2014-10-24 16:47:59 +0200
commit:  dc988e871f9df871d9a98b70782dd3c9e350a880
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1133590 - Unable to login in to Red Hat Access in IE

Comment 13 Simeon Pinder 2014-11-03 19:03:30 UTC
Moving to ON_QA as available to test with latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=396547

Comment 14 Jeeva Kandasamy 2014-11-04 12:32:17 UTC
Still I can see this issue in IE9 and IE11.

Version:
JBoss Operations Network
Version : 3.3.0.CR01
Build Number : 08c2f39:6ac97ac
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Comment 16 Libor Zoubek 2014-11-07 17:14:51 UTC
branch:  master
link:    https://github.com/rhq-project/rhq/commit/b333a0250
time:    2014-11-07 18:10:14 +0100
commit:  b333a02502847cce28ded7cb41ea4dbebca6731a
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1133590 - Unable to login in to 'Red Hat Access' in IE
         After investigation with chindley, the issue is fixed on JON
         side, just by adding IE=10; to X-UA-Compatible meta. IE9 won't
         work anyway, because it does not support CORS


branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/5e8348c90
time:    2014-11-07 18:13:19 +0100
commit:  5e8348c903eb6f08fb297afe1d1d1a97a6a12dbd
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1133590 - Unable to login in to 'Red Hat Access' in IE
         After investigation with chindley, the issue is fixed on JON
         side, just by adding IE=10; to X-UA-Compatible meta. IE9 won't
         work anyway, because it does not support CORS
         (cherry picked from commit
         b333a02502847cce28ded7cb41ea4dbebca6731a) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>


Please note that this fix *DID NOT* require rebuild or RHA.war or any other change in RHA angular app. And this fix does *NOT* fix IE9 - this won't be fixed at all, since it is not possible.

Comment 17 Keith Robertson 2014-11-10 16:09:21 UTC
The original problem described in this BZ has been fixed for all browsers *except* IE9. This problem cannot be fixed in IE9 due to IE9's CORS issues.

A support statement like the following is required for IE9:

"The Red Hat Access plug-in for JON does not support IE9."

Comment 22 Libor Zoubek 2014-11-13 22:34:28 UTC
commit:  1f0bda93eda9c2dd145687b989b2b9b17322b3c5
author:  Libor Zoubek - lzoubek@redhat.com
message: Bug 1133590 - Unable to login in to 'Red Hat Access' in IE

             finish reverting commit b333a0250 - semicolon removed

         (cherry picked from commit
         a49bc60a5d00e87d3cc2d0dccf80f067d9960455) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>
         


branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/d23dfe782
time:    2014-11-13 22:40:23 +0100
commit:  d23dfe78212d8f6ee7f72c6a5bb51f4aae566555
author:  Libor Zoubek - lzoubek@redhat.com
message: Brevert 5e8348c903eb6f08fb297afe1d1d1a97a6a12dbd

         Bug 1133590 - Unable to login in to 'Red Hat Access' in IE


I had to revert Commit mentioned in #c16 as it caused regressions in whole JON UI in IE.

Jared, we need to document, that RHA will *NOT* work in *ANY* version if IE in JON.

Comment 24 Jared MORGAN 2014-11-19 04:46:20 UTC
From a docs perspective, this is covered in the Release Notes for 3.3. If all dev work is done, I guess this can be closed off.


Note You need to log in before you can comment on or make changes to this bug.