Bug 113369 - huge POST data corrupt (PHP #19263)
huge POST data corrupt (PHP #19263)
Status: CLOSED DUPLICATE of bug 82967
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
9
All Linux
high Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 05:26 EST by Robert Scheck
Modified: 2007-03-27 00:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-01-13 05:26:43 EST
Description of problem, how reproducible & steps to reproduce:
The first one:
If I upload a file using the file upload example from the php website,
all I get are corrupted files. The resulting files are about two times
bigger then the input files. The amount of bytes on the output varies a
little bit. This does not happens with files of 10 Kb, but different
files which vary from 60-120 Kb got corrupted.

The second one:
If I post text in a textarea, nothing goes wrong. But if I post a lot of
text in a textarea, parts of the text is copied into the text itself.
For instance, I copied the source of http://www.php.net (normal HTML
source) in a textarea. Posted the data to info.php (this script only has
the phpinfo() function, so I can see all data). The sourcecode of the
php website is 376 lines long. The result is about 734 lines. This is
around twice as big (The site looks really weird ;-))

Well, this text is copied, but I had got still *exactly* the same annoying problem!

More at: http://bugs.php.net/bug.php?id=19263

Version-Release number of selected component (if applicable):
php-4.2.2-17.2

Actual results:
Change the following in php.conf in /etc/httpd/conf.d to something 
better and working :)

--- snipp ---
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    LimitRequestBody 524288
</Files>
--- snapp ---

Change it to that:

--- snipp ---
# PHP 3
AddType application/x-httpd-php3 .php3
AddType application/x-httpd-php3-source .phps
AddType application/x-httpd-php3 .phtml

# PHP 4
AddType application/x-httpd-php .php
AddType application/x-httpd-php .php4
AddType application/x-httpd-php-source .phps
--- snapp ---

Expected results:
Change it as soon as possible ;-)

Additional info:
That bug is horrible to many many users...
Maybe you've got to fix that problem in RHEL, too? In Fedora and Fedora Development all looks fine, but you only use there 
"AddType application/x-httpd-php .php", and not all possibilities I listed above :-(
Comment 1 Joe Orton 2004-01-13 09:33:25 EST
This is bug 82967, and the workaround was included in the -17.2 erratum.

Can you double check that you are using php-4.2.2-17.2 on a server
which exhibits these symptoms?  I can't reproduce any POST body
corruption issues here using the -17.2 packages.
Comment 2 Robert Scheck 2004-01-13 10:27:45 EST
Hm okay, wasn't reproducable at the computers after an reinstall 
of the latest offered httpd and php packages in the up2date 
section...sorry!

*** This bug has been marked as a duplicate of 82967 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.