Bug 113371 - Anaconda seems to not install grub on the MBR
Anaconda seems to not install grub on the MBR
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 05:51 EST by Paolo C.
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 12:00:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo C. 2004-01-13 05:51:23 EST
Description of problem:

I installed fc1 but when I boot the machine I can only boot windowsXp,
there is no sign of grub ( I installed it the MBR)

Info:

Command (m for help):
Disk /dev/hda: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1            15      3738  29912998+   7  HPFS/NTFS
/dev/hda2   *         1        14    112423+  83  Linux
/dev/hda3          3739      4997  10112917+  83  Linux

Partition table entries are not in disk order
Command (m for help):
Disk /dev/hdb: 8455 MB, 8455200768 bytes
255 heads, 63 sectors/track, 1027 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1       897   7205121    b  Win95 FAT32
/dev/hdb2           898      1027   1044225   82  Linux swap


Ed il grub.conf:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this
file # NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/hda3
#          initrd /initrd-version.img
boot=/dev/hda
default=1
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
        root (hd0,1)
        kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
        initrd /initrd-2.4.20-8.img
title DOS
        rootnoverify (hd0,0)
        chainloader +1

Boot the machine with the linux cd and perform the following steps 
doesn't solve the problem:
#chroot /mnt/sysimage
#grub-install /dev/hda

Version-Release number of selected component (if applicable):


How reproducible:
Just install grub on the MBR

Steps to Reproduce:
1.
2.
3.
  
Actual results:
I can only boot windowsXP


Expected results:
I expected to have a dual boot machine (XP and Fedora)


Additional info:
Comment 1 Jeremy Katz 2004-01-13 15:42:38 EST
Is your machine somehow booting from hdb instead of hda?  Can you
attach the contents of /boot/grub/device.map?
Comment 2 Paolo C. 2004-01-13 17:18:43 EST
Here it is the content of that file:

# this device map was generated by anaconda
(fd0)     /dev/fd0
(hd0)     /dev/hda

I don't think the machine is somehow booting from hdb because WinXP 
is on hda and is booting fine.

Comment 3 Paolo C. 2004-01-19 10:05:36 EST
Ok, 
the problem it is fixed, 
here it is the whole discussion:
http://marc.theaimsgroup.com/?t=107400816000003&r=1&w=2

I dunno if I have to close the BUG report because
the problem is fixed (I can boot the machine) but a problem is still 
present, the disks are switched.


Note You need to log in before you can comment on or make changes to this bug.