Bug 113375 - couple of compile time problems
Summary: couple of compile time problems
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-pin (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-13 11:19 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 12:48:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-01-13 11:19:16 UTC
Description of problem:

I just tried to compile package bluez-pin-0.20-1, from Redhat
Fedora Core 1.

The compiler said

1.

ui.c:143: warning: no return statement in function returning non-void
ui.c:143: warning: control reaches end of non-void function

Upon checking the source code, I find that function "bluez_pin_request"
has a gboolean return type, but there is no return statement in the 
body of the function.

Suggest add a return statement at the end of the function.

2.

The compiler also says

n.c(80): remark #592: variable "dpy" is used before its value is set

The source code is

  char *dpy = getenv (dpy);

Seems bizarre code to me. I'm not sure what the programmer intended, 
but this code needs rework anyway.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.