Bug 113376 - subscript out of range
subscript out of range
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bonobo (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 06:21 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 08:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-01-13 06:21:32 EST
Description of problem:

I just tried to compile package bonobo-1.0.22-7, from Redhat
Fedora Core 1.

The compiler said

1.

efstool.c(47): warning #175: subscript out of range

The source code is

        passwd[sizeof(passwd)] = 0;

Better code would be

        passwd[ sizeof( passwd) - 1 ] = 0;






Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 d.binderman 2004-05-23 12:46:25 EDT
Still broken in Fedora Core 2
Comment 2 Mark McLoughlin 2004-07-28 08:15:56 EDT
Same goes for what I said in bug #111018 unfortunately. This code is
even more obsolete - the EFS code was never used at runtime AFAIK and
has since been removed from bonobo. Also, the package - being a GNOME
1.4 package - is only kept for compatibitity reasons. Thanks.
Comment 3 David Binderman 2005-03-08 07:15:57 EST
>the EFS code ... has since been removed from bonobo.

Strange. Same bug still appears to exist in the version of bonobo
available 08 March 2005.

>is only kept for compatibitity reasons.

Even stranger. The version number keeps going up, so someone's doing 
some development of it.
Comment 4 Mark McLoughlin 2005-03-08 07:27:08 EST
The package "bonobo" is a GNOME 1.4 package. The GNOME 2.x version is
"libbonobo".

The last version of bonobo released was in December 2002:

  http://ftp.gnome.org/pub/GNOME/sources/bonobo/1.0/

The release number (i.e. from -9 to -10) went up recently because it
was rebuilt with gcc4.

Note You need to log in before you can comment on or make changes to this bug.