Bug 113382 - `make test` for tcl should use localized version of tcl(local libraries)
`make test` for tcl should use localized version of tcl(local libraries)
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcltk (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 07:07 EST by Sysoltsev Slawa
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 19:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sysoltsev Slawa 2004-01-13 07:07:18 EST
Description of problem:
I tried to build tcl from source rpm by Intel compiler and got such linker 
message:
/users/compiler/tc_6/WORK_DIR/BUILD/tcltk-
8.3.5/tclx8.3/unix/runtcl /users/compiler/tc_6/WORK_DIR/BUILD/tcltk-
8.3.5/tclx8.3/unix/tools/genindex.tcl tcl.tlib
/users/compiler/tc_6/WORK_DIR/BUILD/tcltk-8.3.5/tclx8.3/tcl/unix/tcl: 
relocation error: /users/compiler/tc_6/WORK_DIR/BUILD/tcltk-
8.3.5/tclx8.3/tcl/unix/tcl: undefined symbol: __intel_cpu_indicator
make[1]: *** [tcl.tndx] Error 127

The problem is that tcl is being linked finally as:
gcc -pipe -Wall  -rdynamic -Wl,-rpath,/usr/lib   -O -
D__NO_STRING_INLINES -D__NO_MATH_INLINES -Wall -
Wconversion -Wno-implicit-int  tclXAppInit.o -
L/users/compiler/tc_6/WORK_DIR/BUILD/tcltk-8.3.5/tclx8.3/tcl/unix -
ltclx8.3 -L/users/compiler/tc_6/WORK_DIR/BUILD/tcltk-
8.3.5/tcl8.3.5/unix -ltcl8.3   -ldl  -lieee  \
    -o tcl || (rm -f tcl; exit 1)

and therefore expect the libraries it was linked with are in /usr/lib when it 
run. But while doing `make test` it is not true yet. In /usr/lib previous tcl 
libraries may be, therefore such way built tcl will link with foreign tcl 
shared libraries being run, and that might cause an run-link error (what 
is happened if use distinct from gcc compiler). This way `make check` 
fails and I so cannot build/install source rpm. To clean up this issue I’d 
propose to build localized version of tcl along with ‘normal’ for `make 
test` (with rpath set to where just built libraries resides) and use it for 
`make test`. `make install` then would install ‘normal’ version of tcl.


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. get the Intel compiler
2. try to build tcltk source rpm by Intel compiler on the system where 
some version tcl is already installed.
  
Actual results:
run-time error during run-time linking running tcl.

Expected results:
smoothly built and installed tcl

Additional info:

Note You need to log in before you can comment on or make changes to this bug.