Bug 1133843 - [VLC] dlopen: cannot load any more object with static TLS
Summary: [VLC] dlopen: cannot load any more object with static TLS
Keywords:
Status: CLOSED DUPLICATE of bug 1124987
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 21
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-26 09:21 UTC by Ankur Sinha (FranciscoD)
Modified: 2016-11-24 12:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-26 14:29:29 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1124987 None None None Never

Internal Links: 1124987

Description Ankur Sinha (FranciscoD) 2014-08-26 09:21:16 UTC
Description of problem:
I can't get vlc from rpmfusion to run on F21. It keeps throwing this error:

> [0x1ee0598] dbus interface debug: Getting property CanGoPrevious
> [0x7ff060eaabd8] main decoder warning: cannot load module `/usr/lib64/vlc/plugins/codec/libavcodec_plugin.so' (dlopen: cannot load any more object with static TLS)
> [0x7ff060eaabd8] main decoder error: corrupt module: /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
> [0x7ff060eaabd8] main decoder debug: no decoder modules matched

I saw the calibre bug https://bugzilla.redhat.com/show_bug.cgi?id=1124987 and tried the scratch build in the comment which fixed the issue: http://koji.fedoraproject.org/koji/taskinfo?taskID=7429597

Version-Release number of selected component (if applicable):
[asinha@localhost  ~]$ rpm -qa \*glibc\*
glibc-2.19.90-34.fc21.x86_64
glibc-debuginfo-2.19.90-34.fc21.x86_64
glibc-devel-2.19.90-34.fc21.x86_64
glibc-headers-2.19.90-34.fc21.x86_64
glibc-debuginfo-common-2.19.90-34.fc21.x86_64
glibc-common-2.19.90-34.fc21.x86_64
[asinha@localhost  ~]$

How reproducible:
Always. I couldn't get vlc to run even once. 

Steps to Reproduce:
1. Install vlc from rpmfusion on F21
2. try to run any file
3.

Actual results:
Fails with dlopen error

Expected results:
vlc should run properly.

Additional info:

Comment 1 Carlos O'Donell 2014-08-26 14:29:29 UTC

*** This bug has been marked as a duplicate of bug 1124987 ***


Note You need to log in before you can comment on or make changes to this bug.