Bug 1133933 - Deploying EAP Patch to RHQ/EAP Resource Crashes EAP Service
Summary: Deploying EAP Patch to RHQ/EAP Resource Crashes EAP Service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ER03
: JON 3.3.0
Assignee: Lukas Krejci
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-10, PRODMGT-544
TreeView+ depends on / blocked
 
Reported: 2014-08-26 13:23 UTC by Matt Mahoney
Modified: 2014-12-11 14:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:05:13 UTC
Type: Bug


Attachments (Terms of Use)
server.log (931.80 KB, text/plain)
2014-08-26 13:23 UTC, Matt Mahoney
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1135034 None None None Never

Internal Links: 1135034

Description Matt Mahoney 2014-08-26 13:23:17 UTC
Description of problem:
Deploying a jboss-eap-6.2.4.CP.zip Patch to EAP/RHQ Resource resulted in the following ERROR:

08:29:57,862 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        at org.jboss.as.server.ServerService.boot(ServerService.java:321) [jboss-as-server-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:254) [jboss-as-controller-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]
Caused by: java.io.FileNotFoundException: /home/hudson/jon-server-3.3.0.ER01/jbossas/standalone/configuration/standalone.xml (No such file or directory)
        at java.io.FileInputStream.open(Native Method) [rt.jar:1.7.0_45]
        at java.io.FileInputStream.<init>(FileInputStream.java:146) [rt.jar:1.7.0_45]
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:129) [jboss-as-controller-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        ... 3 more

08:29:57,866 FATAL [org.jboss.as.server] (Controller Boot Thread) JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.



Version-Release number of selected component (if applicable):
JON 3.3 ER01.1

How reproducible:
Always

Steps to Reproduce:
1. Create a Compatibility Group that contains only the RHQ/EAP Resource.
2. Create a Bundle Distribution with jboss-eap-6.2.4.CP.zip for RHQ/EAP Compatibility Group.
3. Deploy EAP patch jboss-eap-6.2.4.CP.zip to EAP Compatibility Group.

Actual results:
RHQ/EAP server failure.

Expected results:
No service failures should occur.

Additional info:

Comment 1 Matt Mahoney 2014-08-26 13:23:57 UTC
Created attachment 930981 [details]
server.log

Comment 7 Lukas Krejci 2014-09-09 13:40:59 UTC
PR submitted: https://github.com/rhq-project/rhq/pull/121

Comment 8 Thomas Segismont 2014-09-10 15:55:04 UTC
Merged in release/jon3.3.x

commit 4cedda3a24228c93f0621e3c0aa8dd6043043e32
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Wed Sep 10 16:57:51 2014 +0200

    BZs 1136996 1135034 1135107 - Check if patching is supported before trying to perform it on EAP based resource
    
    From patch file created with "git diff a3a59ff 5c39e3a"

Comment 9 Simeon Pinder 2014-09-17 02:49:40 UTC
Moving to ON_QA as available for test with the following brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=385149


Note You need to log in before you can comment on or make changes to this bug.