Bug 1133936 - Provide some usable canned resource_limits profiles
Summary: Provide some usable canned resource_limits profiles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-26 13:29 UTC by Luke Meyer
Modified: 2014-09-11 20:06 UTC (History)
6 users (show)

Fixed In Version: rubygem-openshift-origin-node-1.23.9.20-1.el6op
Doc Type: Enhancement
Doc Text:
Previous releases of OpenShift Enterprise shipped a single example /etc/openshift/resource_limits.conf configuration file on nodes for a gear profile called "small". This enhancement adds additional configuration files based on other example gear profiles and host types. For example, files for "medium" and "large" example profiles are included, as well as an "xpaas" profile for use on nodes hosting xPaaS cartridges in future OpenShift Enterprise releases. The contents in the example configuration files have also been rearranged to make it easier for administrators to find commonly customized settings. Specifying a profile of "small", "medium", "large", or "xpaas" when installing a node using the installation scripts now causes the corresponding example configuration file to be deployed. Custom profiles can be used in this way as well, as long as a corresponding configuration file is present during installation.
Clone Of:
Environment:
Last Closed: 2014-09-11 20:06:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1183 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.1.6 bug fix and enhancement update 2014-09-12 00:06:21 UTC

Description Luke Meyer 2014-08-26 13:29:54 UTC
Description of problem:

The node RPM ships only one default profile with no variations. Ship some variations and enable the installer to use them.

Steps to Reproduce:
1. Install via openshift.sh / oo-install with a node profile set to medium or large (or xpaas)
2. Check /etc/openshift/resource_limits.conf

Actual results:
Same default (small) profile with just the name changed.

Expected results:
Settings in the file actually different from the small, copied from example files.

Additional info:

Comment 1 openshift-github-bot 2014-08-28 20:32:33 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/13ef28ff05b8618026bd2d839e7a03d4877758da
node conf: supply resource_limit.conf examples

Bug 1133936 - Provide some usable canned resource_limits profiles
https://bugzilla.redhat.com/show_bug.cgi?id=1133936

Additionally, reorganizes resource_limits.conf a little bit to make it a
little easier for an administrator to find common things they want to
change.

Finally, modified resource_limits.conf defaults to be in line with
a small m3.xlarge host. The CPU constraints are relaxed a bit and
max_active_gears is lowered to be more conservative. A README is added
to indicate that customers are expected to customize this.

Comment 4 Luke Meyer 2014-08-29 13:34:38 UTC
Please test along with https://github.com/openshift/openshift-extras/pull/442

Comment 6 Anping Li 2014-09-01 07:35:50 UTC
Verified and pass on puddle-2014-08-29.11 using openshift.sh/oo-install. 

1) The resource are installed.
[root@rhel65 openshift]# ls -1 resource_limits.conf*
resource_limits.conf
resource_limits.conf.large.m3.xlarge
resource_limits.conf.medium.m3.xlarge
resource_limits.conf.README
resource_limits.conf.small.m3.xlarge
resource_limits.conf.xpaas.m3.xlarge

2) The resource resource_limits file can be deployed correctly.

Comment 8 errata-xmlrpc 2014-09-11 20:06:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1183.html


Note You need to log in before you can comment on or make changes to this bug.