Bug 1134021 - pulp-manage-db drops and rebuilds all indices every run
Summary: pulp-manage-db drops and rebuilds all indices every run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: Unspecified
Hardware: x86_64
OS: All
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks: sat6-pulp-future
TreeView+ depends on / blocked
 
Reported: 2014-08-26 16:06 UTC by Randy Barlow
Modified: 2019-09-25 21:28 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:10:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Pulp Redmine 502 Normal CLOSED - CURRENTRELEASE pulp-manage-db drops and rebuilds all indices every run Never

Description Randy Barlow 2014-08-26 16:06:01 UTC
Description of problem:
Every time pulp-manage-db is run, it drops all DB indices and rebuilds them. This is very inefficient.

Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
Very

Steps to Reproduce:
1. Run pulp-manage-db on a Pulp installation with data (repos with units, for example).

Actual results:
Observe that it takes a while before applying migrations.

Expected results:
There is no need to drop indices that we are going to just regenerate.

Additional info:
If we switch to Mongoengine, it will take care of index management for us.

Comment 1 Brian Bouterse 2015-02-28 22:16:52 UTC
Moved to https://pulp.plan.io/issues/502

Comment 2 RHEL Product and Program Management 2015-03-04 11:24:12 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 pulp-infra@redhat.com 2015-06-15 19:00:49 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 6 pulp-infra@redhat.com 2015-11-06 20:01:19 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 10 Brian Bouterse 2016-04-22 10:47:57 UTC
This looks like the expected output to me.

Comment 12 Jitendra Yejare 2016-04-25 06:51:40 UTC
As per comment 9 of output from Sat 6.2 snap 9.0 and the comment 11 of confirmation of expected behavior, I am moving this bug to verified.

Comment 14 errata-xmlrpc 2016-07-27 09:10:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.