Bug 113414 - Unneeded dependency on librpm*
Unneeded dependency on librpm*
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 12:56 EST by Trever Adams
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 04:16:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2004-01-13 12:56:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Galeon/1.3.11a

Description of problem:
As of Jan 13, 2004, I cannot install the popt and rpm updates for the
devel line of fedora.  This is because net-snmp is saying it needs
rpm-4.1.xxxx.

Unless I completely misunderstand snmp and how it works, why does
net-snmp depend on librpm*anything?  It seems like a bogus dependency.

If not, net-snmp needs to be rebuilt when librpm is.

Version-Release number of selected component (if applicable):
net-snmp-5.1-4

How reproducible:
Always

Steps to Reproduce:
1. Install the new net-snmp
2. Try to install the new popt or rpm updates

    

Actual Results:  Failure on installing popt/rpm because net-snmp needs
older versions.

Expected Results:  Installation should have gone fine.

Additional info:
Comment 1 Jim Cornette 2004-01-13 18:16:10 EST
I have had many problems because of the conflicts. One program killing
a whole system with the conflict due to rpmlib.

I have submitted another bug similat to this problem. I hope the dep
problem is corrected soon.
Comment 2 Kaj J. Niemi 2004-01-14 03:36:54 EST
librpm is not a bogus dependency - you might want to take a look at
the HOST-RESOURCES-MIB.

You're able to query via SNMP what rpms have been installed:

% snmpwalk -v 2c -c foo quux .1.3.6.1.2.1.25.6

Comment 3 Phil Knirsch 2004-01-14 04:16:51 EST
correct. ^^
closing as not a bug.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.