Bug 113428 - /usr/bin/spamd contains invalid buildroot paths hard coded into internal variables
/usr/bin/spamd contains invalid buildroot paths hard coded into internal vari...
Status: CLOSED DUPLICATE of bug 90202
Product: Red Hat Raw Hide
Classification: Retired
Component: spamassassin (Show other bugs)
1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 15:37 EST by Mike A. Harris
Modified: 2007-04-18 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-01-13 15:37:37 EST
Description of problem:

From /usr/bin/spamd on an AMD64 system:

#!/usr/bin/perl -T -w

eval 'exec /usr/bin/perl -T -w -S $0 ${1+"$@"}'
    if 0; # not running under some shell
#############################################################
# The code in this file is copyright 2001 by Craig Hughes   #
# It is licensed for use with the SpamAssassin distribution #
# under the terms of the Perl Artistic License, the text of #
# which is included as the file named "License"             #
#############################################################

my $PREFIX = '/usr/src/build/311522-x86_64/install//usr';  #
substituted at 'make' time
my $DEF_RULES_DIR =
'/usr/src/build/311522-x86_64/install//usr/share/spamassassin';  #
substituted at 'make' time
my $LOCAL_RULES_DIR =
'/usr/src/build/311522-x86_64/install//etc/mail/spamassassin';  #
substituted at 'make' time
use lib
'/usr/src/build/311522-x86_64/install//usr/lib/perl5/vendor_perl/5.8.1';
# substituted at 'make' time


Same thing occurs on x86, and presumeably other architectures
as well.  I noticed this while trying to figure out why spamd
crashes on AMD64, then confirmed it on x86 as well.

Someone else is filing the bug report on it crashing on AMD64 I
believe.  I had a look, and my first guess is that it is due
to it installing its files in /usr/lib instead of /usr/lib64, which
implies that spamassassin might be broken on stock installs of
RHEL 3 on AMD64, PPC64 and s390x (assuming we ship it on those
platforms).  Nonetheless it's worth fixing.  Chuck Mead said
he'll be filing a report later on it.  Feel free to CC me on it
if you like, as I'm interested too.  ;o)



Version-Release:  2.6.0-2


TIA
Comment 1 Chuck Mead 2004-01-13 23:23:53 EST
I have exactly the same problem on my system!

[csm@stealth csm]$ rpm -q spamassassin
spamassassin-2.60-2
Comment 2 Miloslav Trmac 2004-01-14 02:46:22 EST
Duplicate of bug 90202.
Triage->Duplicate 90202
Comment 3 Mike A. Harris 2004-01-15 05:05:48 EST

*** This bug has been marked as a duplicate of 90202 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.