Bug 1134285 - Open a file in a mounted WebDAV drive and LibreOffice asks for user and password
Summary: Open a file in a mounted WebDAV drive and LibreOffice asks for user and password
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
(Show other bugs)
Version: 20
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-27 08:27 UTC by Yajo
Modified: 2015-04-21 19:20 UTC (History)
6 users (show)

Fixed In Version: libreoffice-4.3.6.2-9.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-21 19:20:57 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LO auth window. (21.88 KB, application/octet-stream)
2014-08-27 08:27 UTC, Yajo
no flags Details

Description Yajo 2014-08-27 08:27:37 UTC
Created attachment 931340 [details]
LO auth window.

Description of problem:
User and password should be not needed, because the DAV drive is mounted already in Nautilus.


Version-Release number of selected component (if applicable):
fuse-2.9.3-2.fc20.x86_64
libreoffice-4.2.6.2-1.fc20.x86_64
nautilus-3.10.1-4.fc20.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Connect to a WebDAV server trhough Nautilus.
2a. Open LibreOffice Writer, write something and save to that remote drive.
2b. Double-click on any ODF file in the remote drive.


Actual results:
See screenshot.

Expected results:
File should be just opened/saved, because the authentication is managed by Nautilus.

Additional info:
Maybe related to Bug 961456? However here there is no error, just a redundant authentication system.

Comment 1 Caolan McNamara 2014-08-27 09:20:42 UTC
we don't use the generic gio connection for webdav protocols, we do for e.g. smb://, but not for certain ones and webdav is one of those.

I'm not sure if there is any particular *reason* for that, e.g. access to stuff not provided via gio, or if its just because we had webdav support before we had gio support and default to the pre-existing protocol handlers

Comment 2 Stephan Bergmann 2015-04-14 09:04:38 UTC
Quoting <http://cgit.freedesktop.org/libreoffice/core/commit/?id=51e0d789c344547956764c3b5f0ef5a304f4e0aa>:

"rhbz#1134285: Access dav, davs URLs via GVFS so that LO shares the credentials with Nautilus once the connection has been set up in Nautilus.

"The reason the (non-standard) dav, davs URLs used by GNOME's old GnomeVFS and successor GVFS/GIO were handled via LO's webdav UCP rather than the GNOME- specific gnomevfs resp. gio UCP since b07a5fcc600ad564315d36fbd18495184fdf69cf 'INTEGRATION: CWS tkr10: i84676 neon and gnome-vfs2' is discussed at <https://bz.apache.org/ooo/show_bug.cgi?id=84676> 'mixing neon and the hidden embedded contents old [sic] another neon inside libhttp.so of gnome-vfs2 is unreliable' and only pertains to the legacy gnomevfs UCP, not the new gio one. So keep handling dav, davs URLs via LO's internal webdav UCP under legacy --enable-gnome-vfs, but handle them via the GNOME-specific gio UCP under the default --enable-gio [which is what gets used in Fedora]."

Comment 3 Fedora Update System 2015-04-15 12:22:34 UTC
libreoffice-4.3.6.2-9.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libreoffice-4.3.6.2-9.fc21

Comment 4 Fedora Update System 2015-04-18 09:35:21 UTC
Package libreoffice-4.3.6.2-9.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.3.6.2-9.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6287/libreoffice-4.3.6.2-9.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-04-21 19:20:57 UTC
libreoffice-4.3.6.2-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.