Bug 1134366 - [engine-backend] Creation of an OVF_STORE disk on a gluster domain fails because shareable disk on Gluster domain is not supported
Summary: [engine-backend] Creation of an OVF_STORE disk on a gluster domain fails beca...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Liron Aravot
QA Contact: Elad
URL:
Whiteboard: storage
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-27 11:56 UTC by Elad
Modified: 2016-02-10 17:38 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-17 12:26:35 UTC


Attachments (Terms of Use)
engine.log (386.37 KB, application/octet-stream)
2014-08-27 11:56 UTC, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 32034 master MERGED core: create OVF store as non shareable on gluster domain Never
oVirt gerrit 32185 ovirt-engine-3.5 MERGED core: create OVF store as non shareable on gluster domain Never

Description Elad 2014-08-27 11:56:44 UTC
Created attachment 931431 [details]
engine.log

Description of problem:
OVF_STORE disks fail to be created on a Gluster domain because they are shareable and for some reason, shared disks are not supported on a Gluster domain.

Version-Release number of selected component (if applicable):
ovirt-3.5 RC1.1
ovirt-engine-3.5.0-0.0.master.20140821064931.gitb794d66.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a Gluster storage domain
2. Wait for engine to create an OVF_STORE disk on this domain

Actual results:
Creation fails with a CanDoAction message in engine.log:

2014-08-27 14:40:13,023 INFO  [org.ovirt.engine.core.bll.CreateOvfVolumeForStorageDomainCommand] (DefaultQuartzScheduler_Worker-15) [49e9af2a] Running command: CreateOvfVolumeForStorageDomainCommand internal: true
. Entities affected :  ID: ccf133e6-3710-40a6-9ebb-031ed5ca15af Type: Storage
2014-08-27 14:40:13,029 WARN  [org.ovirt.engine.core.bll.AddDiskCommand] (DefaultQuartzScheduler_Worker-15) [ceb144f] CanDoAction of action AddDisk failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__VM_DISK,ACTION_TYPE_F
AILED_SHAREABLE_DISKS_NOT_SUPPORTED_ON_GLUSTER_DOMAIN



Expected results:
Since the OVF_STORE disk is created as a shareable and we don't support shared disks on Gluster domain, engine shouldn't try to upload them to the domain.
Other option would be to create those disks as non-shareable. 

Additional info:
engine.log

Comment 1 Elad 2014-09-30 12:31:28 UTC
OVF_STORE disk on gluster domain is now created as non-shareable.

Verified using rhev3.5 vt4

Comment 2 Sandro Bonazzola 2014-10-17 12:26:35 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.