Bug 1134507 - Installing Fedora Server F21 Alpha TC4 from network tree crashes
Summary: Installing Fedora Server F21 Alpha TC4 from network tree crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F21AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-08-27 16:11 UTC by Stephen Gallagher
Modified: 2014-09-05 16:12 UTC (History)
10 users (show)

Fixed In Version: anaconda-21.48.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-05 16:12:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Stephen Gallagher 2014-08-27 16:11:44 UTC
Description of problem:
Anaconda crashes with the error message "Fatal I/O Error 11 (Resource temporarily unvailable) on X server :1."

Version-Release number of selected component (if applicable):
Unsure; whatever was on the TC4 media

How reproducible:
Every time

Steps to Reproduce:
1. Install an F21 Server VM over the network, pointing at "http://dl.fedoraproject.org/pub/alt/stage/21-Alpha-TC4/Server/x86_64/os/"
2. Select only the default options

Actual results:
Installation should complete successfully.

Expected results:
Installation crashes with the above message.

Additional info:
It is possible that this is related to a wide ongoing US network outage and not Fedora's fault. Installing Fedora Server 21 Alpha TC4 from the DVD ISO works correctly.

Comment 1 Fedora Blocker Bugs Application 2014-08-27 16:13:31 UTC
Proposed as a Blocker for 21-alpha by Fedora user sgallagh using the blocker tracking app because:

 "When doing a graphical install using the dedicated installer images, the installer must be able to install each of the release blocking desktops, as well as the minimal package set."

Comment 2 David Shea 2014-08-27 16:48:36 UTC
Please attach the log files from /tmp to this bug as individual, text/plain attachments.

Comment 3 Adam Williamson 2014-08-27 16:55:35 UTC
Discussed at 2014-08-27 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2014-08-27/f21-blocker-review.2014-08-27-15.59.log.txt . Accepted as a blocker, under a different criterion (for clarity): "When using the dedicated installer images, the installer must be able to use either HTTP or FTP repositories (or both) as package sources. The network install image must default to a valid publicly-accessible package source." , https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria#Remote_package_sources .

Comment 4 Vratislav Podzimek 2014-08-27 17:12:20 UTC
I believe we already have this fixed on master. Porting the patch and let's see if it helps.

Comment 5 Stephen Gallagher 2014-08-27 19:07:15 UTC
(In reply to David Shea from comment #2)
> Please attach the log files from /tmp to this bug as individual, text/plain
> attachments.

Given comment #4, I will wait and re-test when TC5 becomes available. I don't have an easy way to get the logs off the VM at this time.

Comment 6 Mike Ruckman 2014-09-03 17:35:05 UTC
Discussed in 2014-09-03 Blocker Review Meeting. Could we get this retested on a more recent image? Thanks.

Comment 7 Stephen Gallagher 2014-09-05 15:04:17 UTC
I still can't retest this on TC6, as the netinst.iso isn't working (it doesn't point to a usable tree) and the direct virt-manager install from the tree is broken because of the switch to underscores separating the version and the prerelease name.

I'll continue to monitor this.

Comment 8 satellitgo 2014-09-05 15:33:18 UTC
(In reply to Stephen Gallagher from comment #7)
> I still can't retest this on TC6, as the netinst.iso isn't working (it
> doesn't point to a usable tree) and the direct virt-manager install from the
> tree is broken because of the switch to underscores separating the version
> and the prerelease name.
> 
> I'll continue to monitor this.
#server right now:
<sgallagh> OK, to anyone following along at home, the netinstall iso completes successfully IF you point anaconda explicitly at http://dl.fedoraproject.org/pub/alt/stage/21_Alpha_TC6/Server/x86_64/os/

Comment 9 Stephen Gallagher 2014-09-05 15:36:09 UTC
(In reply to satellit from comment #8)
> (In reply to Stephen Gallagher from comment #7)
> > I still can't retest this on TC6, as the netinst.iso isn't working (it
> > doesn't point to a usable tree) and the direct virt-manager install from the
> > tree is broken because of the switch to underscores separating the version
> > and the prerelease name.
> > 
> > I'll continue to monitor this.
> #server right now:
> <sgallagh> OK, to anyone following along at home, the netinstall iso
> completes successfully IF you point anaconda explicitly at
> http://dl.fedoraproject.org/pub/alt/stage/21_Alpha_TC6/Server/x86_64/os/

You collided with my own update saying that...

Actually, on further reflection, I was able to test this by specifying the stage install tree manually in anaconda. Installation completed successfully, so I'm ready to call this bug fixed.

Comment 10 Adam Williamson 2014-09-05 16:12:01 UTC
let's just go ahead and close it, then, fix landed before Bodhi kicked in, 21.48.3 has the f21 tag.


Note You need to log in before you can comment on or make changes to this bug.