Bug 113459 - swap guidlines misleading...
swap guidlines misleading...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhel-ig-x8664 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
Sandra Moore
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 23:49 EST by Johnray Fuller
Modified: 2014-08-04 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-20 12:10:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2004-01-13 23:49:35 EST
The guidelines for swap are a little misleading...

"4.17.4. Recommended Partitioning Scheme...

...If you are unsure about what size swap partition to create, make it
twice the amount of RAM on your machine (but no larger than 2 GB). It
must be of type swap."

Creation of the proper amount of swap space varies depending on a
number of factors including the following (in descending order of
importance):

- The applications running on the machine.
- The amount of physical RAM is installed on the machine.
- The version of the OS.

In general the following rule of thumb works well:

> Swap should equal 2x physical RAM for up to 2 GB of physical RAM and 1x
> RAM above that, but never less than 32 MB.

Using this basic formula, a system with 2 GB of physical RAM would
have 4 GB of swap, while one with 3 GB of physical RAM would have 5 GB
of swap

For systems with really large amounts of RAM (more than 32 GB) you can
likely get away with less (around 1x, or maybe less, of physical RAM).

Unfortunately, allocating swap is more of an art than a science, so
hard rules are not really possible.

One other note, both RHEL 3 and RHEL 2.1 support up to 32 swap files.
However, due to limitations in the mkswap application under RHEL 2.1,
the maximum size of those partitions or files can be no larger than 2
GB. The version of mkswap which ships with RHEL 3 does not have this
restriction.

Hope that helps!

Johnray
Comment 1 Suzanne Hillman 2004-01-15 15:00:26 EST

*** This bug has been marked as a duplicate of 113458 ***
Comment 3 Sandra Moore 2004-05-20 12:10:28 EDT
This has been added to the recommended partitioning section of the
Install Guide. Changes will be reflected in the next release of the
documentation. Thanks for the excellent feedback, Johnray. :-)
Comment 4 masanari iida 2004-11-01 07:30:42 EST
Swap partition section of the "install guide" on web is still confusing.
http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/x8664-multi-install-guide/s1-diskpartitioning.html#S2-DISKPARTRECOMMEND

 - Max single swap partition size... is this 2GB for _ALL_ RHEL3
   supported arch?  Say, those 64bit stuff, is it still 2GB?

 - I found RHAS 3 installer (anaconda, disk druid) accept larger than 
   2GB swap space (ex. 4GB) during the install. Is this supported?
   The hardware is IA32(NOT EM64T or AMD64)

 - Max number of swap partitions that kernel support... 16 or 32?

I hope you will revise the Install guide, such as create a matrix of
supported swap space and CPU architectures. Also put this info on RHEL's
system limit configuration page.  (
http://www.redhat.com/software/rhel/configuration/ )

Regards,
masanari
Comment 5 Sandra Moore 2004-11-01 09:33:21 EST
We've made a few changes for the next release of the documentation
since this bug was last updated. I think you'll find the next release
to be improved.


Note You need to log in before you can comment on or make changes to this bug.