Bug 113460 - up2date gives GPG signature error for corrupt downloads
up2date gives GPG signature error for corrupt downloads
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-13 23:55 EST by Bob Cochran
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-15 03:17:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Cochran 2004-01-13 23:55:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Running 'up2date -u' to install this version yeilds the following
up2date error message:

"The package php-4.3.4-1.1 is not signed with a GPG signature.
Aborting...".

Version-Release number of selected component (if applicable):
4.3.4-1.1

How reproducible:
Always

Steps to Reproduce:
1. run up2date -u
2. 
3.
    

Actual Results:  php-4.3.4-1.1 and related packages refuse to install
due to the missing gpg signature.

Expected Results:  php packages, along with httpd and mod_ssl updates
should install normally. 

Additional info:
Comment 1 Joe Orton 2004-01-14 02:03:25 EST
You can get GPG errors from a corrupt download, have you tried
deleting the RPMs out of /var/spool/up2date and downloading them again?
Comment 2 Bob Cochran 2004-01-15 00:59:14 EST
I just did this and that fixed the problem. I apologize for not 
trying this before filing the bug, it did not occur to me. 

I think the error message in up2date should be changed to reflect 
your advice or better yet, up2date should delete and attempt to re-
download packages getting the 'gpg signature' error before reporting 
it as such to the user. Perhaps with some approach that makes sense. 
Comment 3 Joe Orton 2004-01-15 03:17:18 EST
No problem. It looks like there are a few bugs filed against up2date
for that issue already, e.g. bug 111601.

Note You need to log in before you can comment on or make changes to this bug.