Bug 113464 - I get an error "Error 15: File not found" upon first boot after install of Fedora Core
I get an error "Error 15: File not found" upon first boot after install of Fe...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 02:12 EST by Mark Dickson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-25 22:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Dickson 2004-01-14 02:12:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Version: Fedora Core 1

I'm running a dual-boot system; Windows 2k (at least until I get a
stable Linux install working) and Fedora Core 1.  My system specs are
as follows:
* P4 1.7 Ghz
* Riva TNT 2 video card(yep, it's old school)
* Sound Blaster Audigy Platinum
* Asus mobo

I originally tried to install Redhat 9.0 and had problems with X
respawning too fast.  Fedora Core seems to work fine in that respect.
 I get the whole thing installed and then get the following message
when I try to boot Fedora Core:

root (hd0, 4)
file system type is ext 2fs, partition type 0x83
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=/dev/hda6 hdc=ide-scsi
hdd=ide-scsi rhgb

error 15: file not found

I'm not sure what file it's referring to.

I know that most of the problems with Fedora are supposedly with the
actual downloads/CDs, but I checked mine out with md5sum and
everything looked good, so I think my install is relatively clean.  

One further thing that should be noted:  I ran into problems creating
a boot disk.  I tried several times and each time got an error saying
there was some error and that the disk couldn't be written to.  I
tried several different disks to no avail.

In any case, I'm starting to feel like my system hates Linux--just to
spite me.

Version-Release number of selected component (if applicable):
Fedora Core 1

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 1 on a similar system.  I didn't do anything
spectacular.
2.
3.
    

Actual Results:  See "Description"; this occurred several times.

Expected Results:  Fedora should have booted normally.  I wouldn't
really know though, as it's yet to work for me.

Additional info:

That's about it.
Comment 1 Mark Dickson 2004-01-22 14:38:39 EST
Okay, I finally got an installation to take.

I had to install Redhat 7.3 first and then upgrade.  I decided first
to watch Fedora install in text mode, as it yields way more
information.  It seems there was a "fatal region error in the
rpmdb"--in other words there was (and still is) some problem with the
RPM database.  I got everything working sort of okay.  I can't install
new RPMs with the installer, but I can do it manually just fine. 
However, there are still probably some RPMs missing.  Also, there are
dead links--so Fedora thinks that the programs are installed.  I guess
I could go through and check every link manually, uninstalling the
programs that aren't really there...but it seems there should be a
much better way to do this.

I checked the install log, which gave me a "db4 error (-30979)
DB_VERIFY_BAD: database verification failed".  I tried rebuilddb, but
perhaps I did it wrong?  I then ran db_verify and I just get a list of
stuff I don't really understand, but no error messages, really.

I've seen this problem listed elsewhere, so it may be worth linking
them, just in case another newbie like me has the same problem.
Comment 2 Jeff Johnson 2004-01-25 22:15:01 EST
This looks resolved.

Note You need to log in before you can comment on or make changes to this bug.