Bug 113467 - Excel doesn't open read-only files on SAMBA share
Excel doesn't open read-only files on SAMBA share
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 04:46 EST by Rados Gregoric
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 02:04:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rados Gregoric 2004-01-14 04:46:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007

Description of problem:
On samba share read-only users cannot open .xls files directly through
windows explorer.
If double-clicked file.xls in windows 2000 explorer, excel starts and
error message is written: "'file.xls' could not be find. Check the
spelling of the file name..."
Same file could be opened directly from excel (File->Open) 
Tested with MS Office 2000 & Office 97 (and open office 1.1)

Users with R/W access have no problems.

We noticed this problem after migrating from RH7.3 to EHES-3.

It seems, that this is konwn problem in samba, and resloved in samba
ver: 3.0.1
http://www.mail-archive.com/samba@lists.samba.org/msg29702.html



Version-Release number of selected component (if applicable):
samba-3.0.0-14.3E

How reproducible:
Always

Steps to Reproduce:
1.create samba share e.g.
[share]
        comment = myshare
        path = /mnt/share
        valid users = @shrgruop
        allow hosts = x.x.x.
        create mask = 644
        force group = shrgroup
        directory mask = 754
        writable = yes
        browseable = yes
        read list = user2, user3
2. map network drive from windows 2000 as user2 
3. in windows explorer double click on any .xls file
    

Actual Results:  excel starts and file not found message is written

Expected Results:  excel starts and file not found message is written

Additional info:
Comment 1 Jay Fenlason 2004-01-16 23:53:26 EST
I've put RPMs of samba-3.0.2rc1 on 
http://people.redhat.com/fenlason/.samba .  Can you try them and see if 
they resolve your problem.  Note that these are un-qa'd packages of a 
release that is not intended for production use.  If they solve your 
problem, I will attempt to get samba-3.0.2 included in the next quarterly 
update of Red Hat Enterprise Linux 3. 
Comment 2 Rados Gregoric 2004-01-20 02:04:43 EST
Problem is solved with updating to 3.0.2.
Thank you


Note You need to log in before you can comment on or make changes to this bug.