Bug 113468 - Update issue and %post install
Summary: Update issue and %post install
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-01-14 10:20 UTC by Petr Krištof
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 12:15:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Krištof 2004-01-14 10:20:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
After automated update of glibc many system services stopped work.
All services what auths users as samba, openldap, dovecot, squid.
I must restarted they manually.

IMHO, package's '%post install' section should condrestart all these
services, not sshd only.

Version-Release number of selected component (if applicable):
glibc-2.3.2-101.4

How reproducible:
Always

Steps to Reproduce:
.

Additional info:

Comment 1 Miloslav Trmac 2004-01-14 10:28:09 UTC
Related to bug 86339.

Comment 2 Petr Krištof 2004-01-14 11:52:19 UTC
Why not use SysV possibilities?

for i in `ls -al /etc/rc.d/rc3.d/ | cut -c60- | cut -f1 -d' '` ; do \ 
service $i restart; done

Using $RUNLEVEL will be better, but I dont how to set it.


Comment 3 Jakub Jelinek 2004-01-14 12:15:08 UTC
Please see the reasoning in bug #86339.  Not all services need this,
you cannot telinit 1; telinit 3/5 because that could kill what a user
is doing in the mean time and furthermore glibc cannot depend on
the shell being present, so all of its %post has to be in a statically
linked executable.
sshd was chosen to allow admin to take care of the rest of things
or reboot after upgrade.
Services which wish to do something on glibc upgrade can use triggers.


Note You need to log in before you can comment on or make changes to this bug.