Bug 1134780 - Open new EAP CSP case from JON, JBoss EAP 6.3.0 'product' and 'version' not loading automatically
Summary: Open new EAP CSP case from JON, JBoss EAP 6.3.0 'product' and 'version' not l...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: JON 3.3.0
Assignee: Libor Zoubek
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: JON3-11
TreeView+ depends on / blocked
 
Reported: 2014-08-28 09:09 UTC by Jeeva Kandasamy
Modified: 2015-11-02 00:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 08:40:02 UTC
Type: Bug


Attachments (Terms of Use)
version is not loading automatically (105.31 KB, application/octet-stream)
2014-08-28 09:09 UTC, Jeeva Kandasamy
no flags Details

Description Jeeva Kandasamy 2014-08-28 09:09:54 UTC
Created attachment 931783 [details]
version is not loading automatically

Description of problem:
Open new EAP CSP case from JON, JBoss EAP 6.3.0 'product' and 'version' not loading automatically. If JBoss EAP 6.3.0 is on remote machine.

Version-Release number of selected component (if applicable):
JBoss Operations Network	
Version : 3.3.0.ER01
Build Number : 23b3476:f3aa7e7
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Browser: Firefox 31.0

How reproducible:
always

Steps to Reproduce:
1. Configure JBoss EAP 6.3.0 on remote machine (Should not be in the same machine where JON is running)
2. Select the EAP from step #1, right click on EAP instance from inventory tree list
3. Select a menu 'Open Support Case'
4. It's redirecting to open new support case page, But Product and Product Version is not loading automatically.

Additional info: Screen shot is attached

Comment 2 Libor Zoubek 2014-09-01 11:31:53 UTC
This is probably not a bug. 

While opening a new support case We're reading 2 traits (Product Name and Product Version) from EAP resource. If those 2 traits are not yet collected, version & product does not get pre-selected. Those 2 traits collect every 24h (while it initially collects much sooner), which is enough time for customer to get into troubles with EAP and open support case.

I admit 'though, that I could read same info from resource version property, that is detected at discovery time thus available any time. That said, using traits is better, since those values come from EAP management API while resource.version was once parsed from text files or even jar files and seems to be more error prone.

Jeeva, could you verify, version and product name is correctly loaded after making sure you have those 2 trait values?

Comment 3 Jeeva Kandasamy 2014-09-02 06:35:06 UTC
Libor, Yes, it's loading properly after some hours/days. I tested on a machine after 3 days.

Comment 4 Libor Zoubek 2014-09-02 08:40:02 UTC
Thank you Jeeva, 

closing as not a bug


Note You need to log in before you can comment on or make changes to this bug.