Bug 113480 - Versions.getCreationTxn/getLastTxn methods are very slow
Versions.getCreationTxn/getLastTxn methods are very slow
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Che
Jon Orris
:
: 113673 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 08:55 EST by Daniel Berrange
Modified: 2007-04-18 13:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 14:33:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DB explain plan for the problem queries (2.43 KB, text/plain)
2004-01-14 08:55 EST, Daniel Berrange
no flags Details

  None (edit)
Description Daniel Berrange 2004-01-14 08:55:24 EST
Description of problem:
On a mildly loaded DB (8000 content items), the
c.a.versioning.Versions.getCreationTxn/getLastTxn methods are very
slow, taking around 400ms to complete. Amongst other things, these
methods are used by the implementation of the Auditing interface in
VersionedACSObject. So if you call the sequence
 
  item.getLastModifiedUser()
  item.getLastModifiedDate()
  item.getLastModifiedIP()
  item.getCreationUser()
  item.getCrwationDate()
  item.getCreationIP()

Then the page will take 400x6 = 2.4 seconds just getting auditing data.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2004-01-14 08:55:52 EST
Created attachment 96969 [details]
DB explain plan for the problem queries
Comment 2 Richard Li 2004-01-14 08:59:41 EST
which database / version?
Comment 3 Daniel Berrange 2004-01-14 09:03:16 EST
PG 7.3.4 (as distributed with RHEL AS 3). I've also run a full vaccuum
analyze, but it made no improvement.
Comment 4 Richard Li 2004-01-15 12:41:13 EST
One other question: How often is the page containing these API calls
used by the user?

(i.e., is it high priority, or are there other performance issues you
think should be addressed first?)
Comment 5 Daniel Berrange 2004-01-15 12:56:25 EST
Its the CMS item summary page which is fairly important as its in the
critical path for CMS authors. That said, Randy committed patch 39404
that removes use of versioning for storing auditing info, so its no
longer much of an issue. I'm not sure if any other code uses
getCreationTxn/getLastTxn.....
Comment 6 Daniel Berrange 2004-01-20 07:22:11 EST
*** Bug 113673 has been marked as a duplicate of this bug. ***
Comment 7 Vadim Nasardinov 2005-08-03 14:33:43 EDT
stale

Note You need to log in before you can comment on or make changes to this bug.