Bug 1134893 - "dnf update" works as "dnf install" on local package files
"dnf update" works as "dnf install" on local package files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
: Reopened
: 1084181 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-28 08:24 EDT by Nils Philippsen
Modified: 2018-04-11 02:58 EDT (History)
7 users (show)

See Also:
Fixed In Version: dnf-0.6.2 dnf-0.6.4-7.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 02:52:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2014-08-28 08:24:34 EDT
Description of problem:
"dnf update <a list of local package files>" will install package files that aren't yet installed.

I ran into a problem in the current F21 version of httpd and wanted to downgrade to a previous version. To do that I used "koji download-build ... httpd-<version>-<release>", which downloaded all subpackages into a temporary directory, even those I haven't installed yet. Running "dnf update ./*.rpm" wanted to install even these subpackages I hadn't installed before.

Version-Release number of selected component (if applicable):
dnf-0.6.0-1.fc21.noarch
hawkey-0.5.0-2.fc21.x86_64
python-hawkey-0.5.0-2.fc21.x86_64

How reproducible:
Reproducible.

Steps to Reproduce:
1. "dnf update <some not yet installed package(s)>"
2. "dnf download <the same package(s)>"
3. "dnf update <path(s) to the downloaded package file(s)>"

Actual results:
Step 1 will not install the package(s).
Step 3 will install the package(s)

Expected results:
Both steps won't install the not yet installed package(s).

Additional info:
Comment 1 Honza Silhan 2014-09-01 04:35:13 EDT
Hi, thanks for the report. Right, step 3 shouldn't install not-yet-installed packages.
Comment 2 Honza Silhan 2014-09-16 15:23:34 EDT
Fixed in the upstream.
Comment 3 Honza Silhan 2014-09-18 09:26:53 EDT
*** Bug 1084181 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2014-10-05 13:41:55 EDT
dnf-0.6.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.2-1.fc21
Comment 5 Fedora Update System 2014-10-06 01:03:32 EDT
Package dnf-0.6.2-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.2-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12254/dnf-0.6.2-1.fc21
then log in and leave karma (feedback).
Comment 6 Christopher Beland 2015-06-10 12:21:39 EDT
Confirmed this is fixed in dnf-0.6.4-5.fc21.noarch, which is the latest available for stable in Fedora 21.
Comment 7 Fedora Update System 2015-08-28 14:53:55 EDT
dnf-0.6.4-6.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update dnf'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14323
Comment 8 Fedora Update System 2015-09-29 07:19:00 EDT
dnf-0.6.4-7.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-9bcdcdc46b
Comment 9 Fedora Update System 2015-10-02 14:52:09 EDT
dnf-0.6.4-7.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-9bcdcdc46b
Comment 10 Fedora Update System 2015-10-13 02:52:07 EDT
dnf-0.6.4-7.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.