Bug 113502 - mpm_common.h missing from httpd-devel includes.
mpm_common.h missing from httpd-devel includes.
Status: CLOSED DUPLICATE of bug 113257
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Depends On:
  Show dependency treegraph
Reported: 2004-01-14 13:46 EST by Jeff Minelli
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Minelli 2004-01-14 13:46:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Almost exact same problem as 

mod_fastcgi requires mpm_common.h and mpm.h from httpd-devel to
compile. They are missing. More exactly mpm_common.h. I got around the
missing mpm.h by linking it to /usr/include/httpd/ap_mpm.h.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install httpd/httpd-devel
2. grab mod_fastcgi from fastcgi.com and try to compile.

Actual Results:  comilation failed.

Expected Results:  should have compiled cleanly.

Additional info:

Grabbed httpd.SRPM and did 'rpmbuild -bp httpd.spec'.
Copied mpm_common.h from there and put in /usr/include/httpd. Linked
ap_mpm.h to mpm.h
Comment 1 Joe Orton 2004-01-14 15:29:35 EST
Thanks for the report.

*** This bug has been marked as a duplicate of 113257 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.