Bug 113509 - Dual disk dual boot does not setup GRUB properly
Dual disk dual boot does not setup GRUB properly
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 15:10 EST by Steve Fox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 15:31:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Fox 2004-01-14 15:10:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; Galeon)
Gecko/20031114 Galeon/1.3.11a

Description of problem:
I have two hard drives with Fedora on the primary master and Windows
XP on the primary slave. After installing Fedora, when I would select
the Windows boot option from GRUB it would drop me into a GRUB shell.
After Googling I found out that grub.conf was missing a statement. I
added the map statement and it now boots as expected.

title Windows
    map(hd1, hd0)
    rootnoverify(hd1,0)
    chainloader +1

Version-Release number of selected component (if applicable):
Fedora Core 1 installer

How reproducible:
Always

Steps to Reproduce:
See description.

Additional info:
Comment 1 Jeremy Katz 2004-01-14 15:31:06 EST
The map statement isn't always needed (in fact, in most cases it's not
and using it will break things).  The only time it's needed is if you
originally installed windows when the drive was the master and then
later change it to be the slave.
Comment 2 Steve Fox 2004-01-14 16:00:11 EST
Ah. That was the case for me. I installed XP when it was the primary
drive (I think it failed installation when it was a slave), then later
moved it to the slave. Thanks for the response.
Comment 3 n0dalus 2007-02-12 08:11:07 EST
Sorry to dig up such an old bug, but is there any plans to try and detect where
this is needed or provide an install-time option for it (since the bug is closed
as DEFERRED).

Note You need to log in before you can comment on or make changes to this bug.