Bug 11351 - root (/) not unmounted cleanly on ''shutdown -r 0'' or ''shutdown -h 0''
root (/) not unmounted cleanly on ''shutdown -r 0'' or ''shutdown -h 0''
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-10 17:16 EDT by scot
Modified: 2014-03-16 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-21 09:21:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scot 2000-05-10 17:16:14 EDT
I upgraded a Redhat 5.2 system to Redhat 6.2.  I typed: 'linux updates
text' at the boot: prompt.  I used the update floppy when prompted
(update-disk-20000419.img from redhat's site).  Upgrade went ok, but when
doing 'shutdown -r 0' the root filesystem (/) never unmounts cleanly.  I
get a brief message that it's busy.  fsck runs after the system reboots
because / wasn't umounted cleanly.  Other filesystems seem to umount
cleanly.  If I do 'init 1' then 'reboot' or 'halt' / seems to unmount
cleanly.  I've compared init scripts between the 5.2 and 6.2 versions but
don't see anything obvious that's causing this problem.

I didn't have this problem under Redhat 5.2.  I've restored by 5.2 system
from a backup (several times) and tried again and it does the same thing.

I've upgraded one other system and had the same problem but it finally went
away after a few reboots.  I'm not sure why.

System is Cyrix 233MMX, 128M, IDE 10.1GB, IDE cdrom, Adaptec 2940UW SCSI
card.

Can anyone verify this and tell me if there's a fix?
Comment 1 Nalin Dahyabhai 2000-05-11 17:07:59 EDT
Are you in an NIS or NFS environment?  Is /usr on a different filesystem?  Are
there any services with "kill" scripts (those that start with "K") under
/etc/rc.d/rc1.d/ that aren't also under /etc/rc.d/rc0.d/?  It sounds as if you
have a service running that doesn't get shut down when you switch to runlevel 0,
but which does get stopped when you go to runlevel 1.
Comment 2 SB 2000-05-14 18:37:59 EDT
I have the EXACT same problem.  Upgrade from 5.2 to 6.2 would say certain drives
are busy which should not be, however in my case it was not the root file system
it was root's home filesystem /root.  My problem come down to drives that
contains home dirs of users that at some point logged in do not unmount cleanly
at halt.  After othher users have logged in and out the /home filesystem will
not unmount.  I'm still looking into this as in my case it seems like something
with ioctl() seems to come into play somewhere.  When I try to sue fdisk now to
write out partition stuff it gives me:

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.
Re-read table failed with error 16: Device or resource busy.
Reboot your system to ensure the partition table is updated.

This problem has only appeared since the upgrade and the busy thing makes me
think the two could be related...

Any thoughts...?

-Stan Bubrouski
Comment 3 Pekka Savola 2000-05-21 09:21:59 EDT
I have had the same problem too.

Removing a redundant (and IMO too early) read-only remounting of root seemed to
fix this.

Patch against 5.13:
--- init.d/halt~        Wed Apr 19 23:09:44 2000
+++ init.d/halt Sun May 21 15:47:46 2000
@@ -84,7 +84,7 @@
        sig=-9
 done

-mount -n -o remount,ro /
+#mount -n -o remount,ro /

 # turn off raid
 if [ -x /sbin/raidstop -a -f /etc/raidtab ]; then
---
[root and the rest of ext2 partitions get unmounted about 10 lines later anyway,
after proc has been disabled].
Comment 4 Bill Nottingham 2000-05-31 18:39:28 EDT
should be fixed in initscripts-5.14-1.

Note You need to log in before you can comment on or make changes to this bug.