Bug 1135367 - enter_bug.cgi: Keystrokes that don't change the Summary field cause unnecessary searching for duplicate bugs
Summary: enter_bug.cgi: Keystrokes that don't change the Summary field cause unnecessa...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks: UI-Modernization
TreeView+ depends on / blocked
 
Reported: 2014-08-29 07:21 UTC by Jason McDonald
Modified: 2018-03-19 02:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-18 23:12:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1446855 None None None 2018-03-19 02:18:14 UTC

Description Jason McDonald 2014-08-29 07:21:19 UTC
Description of problem:
When creating a new bug, entering text into the Summary field causes Bugzilla to search the database for bugs with similar summaries.

Unfortunately, this searching appears to trigger on any keystroke, where it should only trigger on keystrokes that change the content of the Summary field (and could thus potentially change the results of the search).  Repeating the search for keystrokes that don't change the content of the Summary field just wastes cycles on the Bugzilla servers.

Also, changing the summary field without using the keyboard doesn't trigger a search for possible duplicates.

Version-Release number of selected component (if applicable):
Red Hat Bugzilla 4.4.5024 + firefox 31.0

How reproducible:
Always

Steps to Reproduce:
1. Open https://bugzilla.redhat.com/enter_bug.cgi?product=Bugzilla
2. Type a few random words into the Summary field
3. Press the left arrow key, then observe that the text "Searching for possible duplicates...." appears for a few seconds below the table headings of the Possible Duplicates table, though the contents of the table don't change when the search is complete.
4. Repeat step 3 for various other keystrokes that don't change the content of the Summary field (e.g. Down Arrow, Home, End, Insert, Alt, Ctrl, Shift, CapsLock, Ctrl+A, Ctrl+C, etc).
5. Copy a word into the clipboard.
6. Paste the word into the Summary field with the mouse (i.e. right-click and select Paste from the popup menu).
7. Observe that the search for possible duplicate is not performed.

Actual results:
Unnecessary search for duplicates is triggered by keystrokes that don't change the Summary field.  Necessary search is not triggered by non-keystroke actions that do change the Summary field.

Expected results:
Search for duplicates whenever the Summary field changes and not otherwise.

Additional info:
none

Comment 1 Jeff Fearn 🐞 2018-03-16 02:43:03 UTC
Looks like an upstream bug?

Comment 2 Jason McDonald 2018-03-17 07:51:13 UTC
(In reply to Jeff Fearn from comment #1)
> Looks like an upstream bug?

Yes, it's the same in Landfill BZ5 and our BZ5. Do you want me to report it upstream?

Comment 3 Jeff Fearn 🐞 2018-03-18 23:12:57 UTC
Yes upstream please.

Comment 4 Jason McDonald 2018-03-19 02:18:15 UTC
File upstream as https://bugzilla.mozilla.org/show_bug.cgi?id=1446855.


Note You need to log in before you can comment on or make changes to this bug.